Single Number Reach-SNR

Unanswered Question
Sep 25th, 2009
User Badges:

Hi,


I am facing problem with mobile connect timers setting.


Consider the scenario...i am in canteen some one dials my ip-phone no. i get a simultaneous call on my mobile also....now i reach to my desk while talking on my mobile and now i want to transfer the call back on my IP-Phone. Now in this scenario when i cut the call on my mobile it takes around 30sec for me to resume the call back on my IP-Phone.


Do i am missing any thing here?Pls let me know if any one has solution for this..CUCM version is 7.x


thanks in advance


Rgds,

Alok

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Stoyan Stoitsev Fri, 09/25/2009 - 07:25
User Badges:
  • Bronze, 100 points or more

Hello,


Try to enter

voice call disc-pi-off

in your router that is handling the call to the GSM side.


BR,

Stoyan

jaiswalok Fri, 09/25/2009 - 20:52
User Badges:

Hi Stoyan,


I tried the command, but still it is taking 30 seconds..


is there any other thing which can be done.

James Hawkins Tue, 02/25/2014 - 08:32
User Badges:
  • Gold, 750 points or more

Thank you - this solved the issue on my SIP H323 gateway

chrward Fri, 09/25/2009 - 09:48
User Badges:
  • Cisco Employee,

We sometimes see strange delay and ringing issues like this when the call to the cell phone from CUCM (SNR call) is sent over an unsupported link:


"Mobile Connect features do not get supported for T1 CAS, FXO, FXS and BRI."


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/admin/7_1_2/ccmfeat/fsmobmgr.html#wp1245955


Please make sure you are using a PRI, H323 GW, or SIP trunk from CUCM to the cell phone. Using a different type of trunk will cause unexpected behavior.

jaiswalok Fri, 09/25/2009 - 21:02
User Badges:

Hi,


I am using E1 PRI link..and protocol is MGCP.


consider the following scenarion:

IP-Phone calling Mobile Phone


After conversation mobile user disconnect the call, but still call is flashing on IP-Phone for 30 seconds.


So the timer is same in both the cases. Can we reduced this timer some how.

Stoyan Stoitsev Fri, 09/25/2009 - 22:27
User Badges:
  • Bronze, 100 points or more

Hi,


Since you're using MGCP this command won't work. MGCP back-hauls ISDN messages to CUCM so you have to enable it there. Go to CallManager Service Parameters, click on advanced and in Clusterwide Parameters (Device - PRI and MGCP Gateway)change Convert Progress to Disconnect for User Side PRI EURO to True. Not sure if you need to restart the CCM service.


BR,

Stoyan

jaiswalok Fri, 09/25/2009 - 23:12
User Badges:

Hi Stoyan,


I am not getting any such option in my CCM.


My CCM version is:

System version: 7.0.2.20000-5


However there is a option of "Convert European Progress Message to Alerting" whose current valuse is false.


I set it true and reset the MGCP gateway but still it is not working. Its still taking 30 seconds.


I have read in Cisco documents that 30seconds is default behaviour in SNR.


So does it mean that it can't be changed.

This is what Cisco docs saya about the problem.


Q. Why does the desk phone stay in the Remote In-Use state for up to 30 seconds

after the user hangs up the cell phone?

A. After hanging up the cell phone, the calling party hears the reorder tone and

the desk phone stays in the Remote In-Use state for up to 30 seconds before

moving to the On-Hold state. The desk phone can then resume the call with

the calling party. The delay occurs because the mobile carrier waits before

sending a disconnect message to Cisco Unified Communications Manager,

probably to avoid false disconnects.

Stoyan Stoitsev Fri, 09/25/2009 - 23:17
User Badges:
  • Bronze, 100 points or more

Hi,


WE had the same issue and found out that CUCM and ISRs keep the call active for 30 seconds is they receive a disconnect with PI in it, which actually quite often.

Did you click on the Advanced button in the service parameters section? If you don't click Advanced you won't see that option!


BR,

Stoyan

jaiswalok Fri, 09/25/2009 - 23:28
User Badges:

Hi Stoyan,


After clicking the Advanced button i got the option.


I set it true and reset the MGCP gateway.


But still it is taking 30 sec. Do you want me to send the router configuration?


or do i need to do any other thing after changing the parameter.


Regds,

Alok

Stoyan Stoitsev Sat, 09/26/2009 - 03:51
User Badges:
  • Bronze, 100 points or more

Hi,


I think you should reset your CCM service for the changes to take effect. Be aware the phones will reset and calls through MGCP GWs will drop.


BR,

Stoyan

jaiswalok Mon, 09/28/2009 - 22:15
User Badges:

Hi Stoyan,


I restarted the server to have the changes take effect.


But still the problem is there..it is taking 30secs.


what else can be done to address this issue.


thanks

alok

Stoyan Stoitsev Mon, 09/28/2009 - 22:57
User Badges:
  • Bronze, 100 points or more

Hello,

The link posted by Christopher says it all (unfortunately we didn't see it):

Only H.323 gateways are supported :(


At our office we are using h.323 and we've had no issues besides the one with the progress indicator. I just checked the feature at a client's HQ with MGCP and it acts quite the same way... If you think it's worth it and you know how to do h.323 you can give it try.


BR,

Stoyan

Carlo Poggiarelli Tue, 02/25/2014 - 08:39
User Badges:
  • Green, 3000 points or more

Hi all.

I know that this could sound strange, but I've a customer with CUCM 8.5 and MGCP gateway connected to an E1 30 ch.... no issues with SNR it takes the time defined in delay before ring parameter on remote destination configuration page.




My 2 cents.


Regards



Carlo



Please rate all helpful posts

"The more you help the more you learn"

Actions

This Discussion