LACP EtherChannel

Unanswered Question
Sep 25th, 2009
User Badges:

I am trying to configure LACP between our Cisco 3750 stack and an EMC SAN.


I have 2 GigabitEthernet ports that I have put into port-channel 20, please see the below config for the 2 interfaces…


interface GigabitEthernet2/0/10

description EMC

switchport trunk encapsulation dot1q

switchport trunk native vlan 101

switchport mode trunk

speed 1000

duplex full

channel-protocol lacp

channel-group 20 mode active

!

interface GigabitEthernet2/0/12

description EMC

switchport trunk encapsulation dot1q

switchport trunk native vlan 101

switchport mode trunk

speed 1000

duplex full

channel-protocol lacp

channel-group 20 mode active


When using the above configuration the links do not come up, the port-channel interface and 2 physical interfaces show as notconnect.


However, when I switch the mode to 'on' (therfore not use a protocol) the etherchannel comes up no problem.


I have been assured that the EMC SAN is configured correctly and is able to use LACP.

I have also tried 'passive' mode with no joy!


Any help is greatly appreciated.


Steve


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Fri, 09/25/2009 - 06:36
User Badges:
  • Purple, 4500 points or more

The switch side looks fine , without seeing the san side which is where the problem probably is it's hard speculate. If it works as "on" then maybe the san is set as on also .

Giuseppe Larosa Sat, 09/26/2009 - 04:00
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Steve,

probably the EMC SAN is not sending LACP messages and the switch after a timer expiration puts the ports in a suspended state.


Check the switch log for LACP related messages with


sh log | inc LACP


By the way, this is the advantage of LACP it can detect problems with the neighbor device.


Hope to help

Giuseppe


Actions

This Discussion