QoS configuration on FE subinterface

Unanswered Question
Sep 25th, 2009
User Badges:

Don't know if this is the right place for the QoS questions...


I just have general question. If I want to guarantee bandwidth for certain traffic which will appear on all the subinterface, can I limit it on the main interface by placing a policy-map on it?


For example I have f0/0 on a 2800Rtr and I have 3 subinterfaces f0/0.1, .2, .3.


ip access-list ex ACL_traffic

permit ip host x.x.x.x any


class-map CMAP_traffic

match access-group name ACL_traffic


policy-map PMAP_traffic

class CMAP_traffic

priority 1000

policy-map PMAP

class class-default

shape average 1500000

service-policy PMAP_traffic


int f0/0

service-policy output PMAP


I did try this and the policy-map did work on both f0/0 and subint f0/0.3. However how does it work if I put it on them? If I put it on f0/0, does it averagely allocate 1/3 of bandwidth to each subinterface if they all have matched traffic and does it allocate all bandwidth to f0/0.1 if there is only traffic on f0/0.1 but not other two subinterfaces? Thanks!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph W. Doherty Fri, 09/25/2009 - 15:52
User Badges:
  • Super Bronze, 10000 points or more

I'm not 100% positive, but believe if you set the policy on the main Ethernet interface, that has subinterfaces, it would apply to all traffic using the interface. To limit its shaping to a particular subinterface, you would use a hierarchical policy on the subinterface (as you noted you tried and worked) or you could define a policy on the main interface with multiple classes, one to match traffic per subinterface, and control the traffic there. (Again, not 100% certain what the policy will "see" on a main interface which has subinterfaces.)

Laurent Aubert Fri, 09/25/2009 - 17:26
User Badges:
  • Cisco Employee,

Hi,


If the traffic you want to protect can come from several subinterfaces, you should apply the service-policy on the main interface. In this case you don't need to shape as the the physical interface speed is used as the implicit shaper.


If you apply your configuration to the main interface, you will not be able to send more than 1.5M total. If you apply PMAP_traffic named service-policy on the main interface, you will be able to use all the interface Bw (100M) and protect the traffic matching CMAP class-map.


Your configuration (called HQOS) is good if you need to apply it on a subinterface because it's a virtual interface so there is no default shaper here.


HTH


Laurent.

Marwan ALshawi Sat, 09/26/2009 - 05:07
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

to add to Laurent's nice comments


if you havt diffrent source/distination

per subinterface

letsay you have two remote sites each will be communicate with one o fhte subinterfaces

site1 10.1.1.0

site 20.1.1.0


access-list 110 per ip any 10.1.1.0 0.0.255

access-list 120 per ip any 20.1.1.0 0.0.255


class-map class1

match acess-group 110


class-map match-all class1-1

ip dscp ef



class-map class2

match acess-group 120


class-map class2-1

match dscp ef


policy-map p1


class1-1

priority 100


policy-map p2


class2-1

priority 100


policy-map main-p


class1

shape average 2000000

service-policy p1

class1

shape average 1500000

service-policy p2


then apply it to the main interface this way you will shape each subinterface to diffrent abmount of bandwith and inside each policy will hsubpolicy that clasify your traffic and give it diffrent treatment


(HQOS)


good lcuk

if helpful rate


Actions

This Discussion