BRI Caller ID

Unanswered Question
Sep 26th, 2009
User Badges:

Hi,


We have a remote site with 4 phones that was using CME but is now on MPLS network and those 4 phones are now registered on CUCM at main site.

We have installed a BRI cards on new router with number 555-1234. The 4 phones have an extension of 34XX.


When any of these 4 phones call out the called person sees the Caller ID of 555-1234 rather than 555-34XX.


When an outbound call is made Debug isdn q931 shows correctly the calling number to be 34XX.


My first question is does BRI lines support CallerID?

If it does can someone point me in the right direction.....as in will i have to consult Telco etc


Many thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Sat, 09/26/2009 - 10:08
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Please send the complete "debug isdn q931".

It may be a type/plan issue or telco wants to receive a different number of digits.

rchaseling Sat, 09/26/2009 - 10:37
User Badges:

*Sep 26 18:32:48.224: ISDN BR0/1/0 Q931: TX -> SETUP pd = 8 callref = 0x6E

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x81

Preferred, B1

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0081, '3240'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '014537900'

Plan:Unknown, Type:Unknown

*Sep 26 18:32:48.492: ISDN BR0/1/0 Q931: RX <- SETUP_ACK pd = 8 callref = 0xEE

Channel ID i = 0x89

Exclusive, B1

*Sep 26 18:32:49.612: ISDN BR0/1/0 Q931: RX <- CALL_PROC pd = 8 callref = 0xEE

*Sep 26 18:32:49.700: ISDN BR0/1/0 Q931: RX <- ALERTING pd = 8 callref = 0xEE

Progress Ind i = 0x8282 - Destination address is non-ISDN

*Sep 26 18:32:54.388: ISDN BR0/1/0 Q931: RX <- CONNECT pd = 8 callref = 0xEE

Progress Ind i = 0x8282 - Destination address is non-ISDN

Date/Time i = 0x09091A131E00

Date (yr-mm-dd) = 09-09-26

Time (hr:mnt:sec) = 19:30:00

paolo bevilacqua Sat, 09/26/2009 - 11:51
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Try sending the full calling number.

Short numbers work only in the US.

rchaseling Sat, 09/26/2009 - 12:39
User Badges:

Just tried it but still the same - q931 debug shows it sending the full calling number - tried all different lengths ie dropping area code also.


It has to be a telco thing i'm guessing.......unless there is special BRI config commands

paolo bevilacqua Sat, 09/26/2009 - 12:50
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Check an incoming call and set length and type/plan to be the same.


Truth is, telco can have set so to overwrite, but that's not typical when you have DIDs.

virverma Sat, 09/26/2009 - 13:06
User Badges:
  • Silver, 250 points or more

From your explanation I understood,


You have a DID from BRI as 555-1234

and extension on phones are 555-34XX


You want caller ID Prefix-+-extension number


Caller id apperance, and the numbers you want to show, can be configured on in the field ExternalPhone Number Mask.


The mask can contain up to 50 characters. Enter the literal digits that you want to appear

in the caller ID information, and use Xs to represent the directory number of the

auto-registered device.


For example, if you specify a mask of 972813XXXX, an external call from extension 1234

displays a caller ID number of 9728131234 if the Use External Phone Number Mask option is

checked on the route pattern used to make the external call.


Try to Follow these instructions:-


1. Select Route Plan

2. Click on Route Pattern

3. Chose the Right Route Pattern with the Gateway to send Call Outside through

PSTN

4. Check Use Calling Party's External Phone Number Mask

5. In Calling Party transform Mask put 55534XX

6. In Calling Party Presentation chose Allowed


Actions

This Discussion