AnyConnect on Ubuntu

Unanswered Question
Sep 27th, 2009

Hello.

I have problem running Cisco Anyconnect VPN Client on my Ubuntu Linux, I cant launch the vpnui application. When I try, I get error.

$ /opt/cisco/vpn/bin/vpnui

GThread-ERROR **: GThread system may only be initialized once.

aborting...

Aborted

Tried reinstall, tried another Ubuntu box and got same results.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 2 (1 ratings)
auraza Mon, 09/28/2009 - 07:01

Please try the following:

/opt/cisco/vpn/bin/vpn connect 1.2.3.4

Establishes a connection to a security appliance with the address 1.2.3.4.

--

/opt/cisco/vpn/bin/vpn connect some_asa_alias

Establishes a connection to a security appliance by reading the profile and looking up the alias some_asa_alias in order to find its address.

--

/opt/cisco/vpn/bin/vpn stats

Displays statistics about the vpn connection.

--

/opt/cisco/vpn/bin/vpn disconnect

Disconnect the vpn session if it exists.

PS. If you found this response helpful, please do rate it. :)

tomas.horacek Mon, 09/28/2009 - 08:09

Thanks for reply Auraza.

All this works. But I would love to have the SysTray icon/app to control the connection.

Is there a chance to fix the app ?

auraza Mon, 09/28/2009 - 08:28

I am not sure I understand what you are looking to do. Are you unable to control the right-click on the icon to control the connection?

tomas.horacek Mon, 09/28/2009 - 08:32

As far I understand, vpnui binary is the application for systray, to control, config the connection, etc.

I am unable to launch the application, so I have no icon at all.

tomas.horacek Tue, 09/29/2009 - 00:43

Tried the installation on another Ubuntu PC. The icon (vpnui) works without a problem.

t.erdin Thu, 03/25/2010 - 07:32

Is there any solution for this problem?

I have the very same behaviour , working with fedora11.

GThread-ERROR **: GThread system may only be initialized once.
aborting...

Command "/opt/cisco/vpn/bin/vpn connect x.x.x.x" works all fine as supposed to, but I can't start vpnui, which means I don't have a Icon to show me the state of the connection.

It would be very helpful if someone could give me a hint how to solve this. (Using another computer is not a option).

jimsiff Sun, 03/28/2010 - 01:04

I would start by making sure AnyConnect knows where to find the GTK libraries used for Gnome.  If you're using KDE as your desktop and don't have GTK installed, the AnyConnect GUI will fail to launch.

dbindner1 Fri, 04/02/2010 - 06:35

I can reproduce this problem:

$ /opt/cisco/vpn/bin/vpnui


GThread-ERROR **: GThread system may only be initialized once.

aborting...
Aborted
It occurs for me when the Gnome Accessibility features are enabled under System->Preferences->Assistive Technologies->[x] Enable assistive technologies.
Don
t.erdin Mon, 04/05/2010 - 23:00

I've tried with "assistive technologies" disabled, but I get the same message.

I'm running Fedora 11 with gnome 2.26.1.

How can I make sure, anyconnect finds all the required libraries?

Is there a way to start vpnui in debug mode?

Here are some lines out of the crash report:

---->

System: Linux 2.6.30.10-105.2.23.fc11.i586 #1 SMP Thu Feb 11 06:51:26 UTC 2010 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10603901
Selinux: Enforcing
Accessibility: Disabled
GTK+ Theme: Nodoka
Icon Theme: Fedora
GTK+ Modules: canberra-gtk-module, pk-gtk-module, gnomebreakpad, gail, atk-bridge

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 0

---- Critical and fatal warnings logged during execution ----

** GThread **: GThread system may only be initialized once.


----------- .xsession-errors ---------------------
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x7400049 (Firefox Up)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x7400049 (Firefox Up)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Registering Enigmail account manager extension.
Enigmail account manager extension registered.
Registering Enigmail account manager extension.
Enigmail account manager extension registered.
gnome-session[2313]: WARNING: Not able to stop app from its condition: Not running
GThread-ERROR **: GThread system may only be initialized once.
aborting...
GThread-ERROR **: GThread system may only be initialized once.
aborting...
--------------------------------------------------

<----

Any more ideas?

t.erdin Tue, 04/06/2010 - 04:46

Oh, disabling "assistive technologies" did the trick.

I just realized, I need to logout and login again before this takes effect.

Even it seems, this is a bug in the anyconnect client, I'm happy with this solution as I don't need the assistive tools.

Thanks.

dbindner1 Tue, 04/06/2010 - 05:44

Yeah, now that Cisco can reproduce it, I expect we'll see a fix.  It would seem from Googling that the change is just a line or two at the beginning of the program, where the thread library is initialized.

dbindner1 Thu, 04/15/2010 - 14:46

Bug ID: CSCtg14425

The bug has Minor severity, and the advice is to "Disable Assistive Technologies," which works for me.

Must be a foreign development group.  I'm guessing that attorneys in the U.S. wouldn't usually let you say your bug isn't important because you have a disability.

pestilence.ath.cx Tue, 05/11/2010 - 11:18

I had the same issue on 32 bit (had no issues on 64 bit on the same system, so I find this very odd).  I installed and saw I had no icons for the program, had errors uninstalling which then led me to resort to 'rm -Rfv /opt/cisco'.

I ended up running 'sudo nautilus' and then double clicked on the install.sh file and BAM everything showed up as normal.

I am running 10.04 up to date as of May-11-2010 and I did not have the assist technology installed (manually removed them after I installed 10.04).

Not sure why doing it with the gui up is any different than running sudo from the CLi.

Actions

Login or Register to take actions

This Discussion

Posted September 27, 2009 at 11:10 PM
Stats:
Replies:13 Avg. Rating:2
Views:2980 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard