SPA941 problems

Unanswered Question
Sep 28th, 2009

I am using the linksys spa941 with latest firmware on a couple of sites and am having the same problems.


I have very limited knowledge in the area of IP Phones so I'd be grateful of any pointers.


The problem seems to occur once a message has been left.

When the message indicator light is on the phone makes a popping / crackling noise (audible whilst sitting at the desk) then the display goes blank, then the 'initializing network' message is displayed, then the phone is OK but no message indicator is on, then the message indicator comes on and the cycle begins again.

This cycle happens every 30 seconds or so and stops when the message is listened to - until next time!


Thanks for your advice.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Patrick Born Mon, 09/28/2009 - 15:57

Hi sirahdigital,


This sounds most unusual.

In order to further troubleshoot, I need information please:

1. Provide the configuration from a phone that exhibits this behavior:

https://www.myciscocommunity.com/docs/DOC-2982

2. Enable debug and capture syslog log when the the MWI is off, then cause MWI to light, then stop logging after phone has rebooted.

https://www.myciscocommunity.com/docs/DOC-3033


What are you using to power the phones?


Regards,



Patrick

----------

sirahdigital Thu, 10/01/2009 - 12:58

Thank you for your assistance and apologies for the delay in replying.


All phones which display this behaviour are powered by mains using the supplied power adapter.


I have attached the html current settings and will reply later with the debug log as requested.


Thank you very much and to clarify this behaviour is occuring on the 2 diferent sites I have deployed these phones, the hosted VOIP provider is the same in both cases.

sirahdigital Fri, 10/16/2009 - 16:06

Hello Patrick


Sorry for the delay - I have now produced the syslog for your examination.


I can confirm that the behavious occurs on the same phones SPA941 using the same hosted voip provider but on different sites.  Whenever a message is left the phone then goes into this cycle of screen blanking, checking DNS every few seconds.


I hope the logs shed some light on this and it turns out to be a setting I have misconfigured or something similar!


Thank you for your time.


Simon

Attachment: 
Patrick Born Tue, 10/20/2009 - 15:56

Hi sirahdigital,


Thanks for the information. I apologize for the delay. I was out on business travel.


Please confirm what you mean by; "the behavious occurs on the same phones SPA941 using the same hosted voip provider but on different sites"

Do you mean:

1. You have one SPA941 and have tried it at two different sites and the problem remains?

Or

2. You have multiple SPA941 phones and have tried them and they all present the identical symptoms?


Looking over your config:

1. Is "0626*100" really your phone's user id? [I've never seen a * in a user id before. Typically this is the phone's extension, example 12345]

2. Your phone is resyncing and rebooting so often because it's config is telling it to do so every 10 seconds:

Provisioning tab > Configuration Profile > Resync Periodic: 10

Consider changing your profile rule as follows:

From:

  10

To:

  7200

3. Do the syslog and phone configuration belong together?

I notice that the phone has an uptime of over 3 days. I see that the phone's time is 20H47 October 1, 2009 yet the syslog is from 23H40 October 16. I notice that the phone does not have a syslog server configured either.

[I appreciate that you captured the syslog and config at different times, I just want to make sure that the config I'm looking at relates to the problem. :-)  ]


It would be good if you can fix the phone reboots by adjusting the periodic resync and then:

1. determine if the problem still exists by leaving a message for the phone

2. If the problem persists, capture a Wireshark trace so I can see what the phone is receiving, capture a new syslog so I can see what the phone thinks it is doing, and provide the most current config of the phone please.


Regards,



Patrick

-----------

sirahdigital Mon, 10/26/2009 - 15:43

Thanks for the info - I have made the changes you suggested and I am sad to say that all it has appeared to do is push the problem 2 hours away ie 7200 seconds.  After this time exactly the same thing happens.


To clarify some points from earlier - the configuration and trace were from the same phone albeit a while a part as you noted.


I am experiencing the same problems at the two locations I have these phones deployed.  Separate phones on separate, non-connected sites with different brand of routers / switches etc.  I even purchased a replacement SPA941 thinking they might have been faulty but the replacement behaves the same way, so either another faulty handset or some other problem!


I will get on with the wireshark trace, but have discovered the download isn't compatible with Windows 7 - so will get a Vista machine sorted to do the trace and new syslog and configuration settings.


Thanks and I'll post back within the next day or so.


Kind regards

Simon

Patrick Born Mon, 10/26/2009 - 16:21

Simon,


Reading your response, I've had a thought. The phones are rebooting after a successful resync. This means that there's a parameter in the phone's config that it receives during resync that tells the phone to reboot in order to make the new parameter take effect. [Look very carefully at the config file, there may be a small syntax error causing this type of behavior]


Consider simplifying a phone's config to just the basics, make sure that things like IP address don't change, then the phone should resync without rebooting.

Review the provisioning guide for pointers: https://www.myciscocommunity.com/docs/DOC-3216


Regards,



Patrick

-----------

sirahdigital Thu, 11/05/2009 - 09:24

Hello Patrick


Thanks for the advice, I'm still having the same problems.  Part of the problem is that I'm not sure what constitutes a syntax error in the config file.  And by config file do you mean the admin pages on the IP address of the phone?


I have noticed on all the handsets with this problem that the resync value which we increased to 7200 resets to the default of 10, even having clicked on the submit all changes button.


I will set up the wireshark trace and run the syslogs again for you to look at.


I am wondering if this has anything to do with the provisioning file that my hosted VOIP company have provided and secondly would a different model of cisco phone have the same problems, could you recommend another  handset, may be a slighty higher spec one.


Many thanks for your continued patience!


Kindly

Simon Kensington

Patrick Born Mon, 11/09/2009 - 17:16

Hi Simon,


You say, "I am wondering if this has anything to do with the provisioning file that my hosted VOIP company have provided and secondly would a different model of cisco phone have the same problems, could you recommend another  handset, may be a slighty higher spec one."

My guess is that yes, it is this provisioning file that may be causing an issue. You set the resync to a long time period and then the phone resyncs. The SP [VoIP company] has a profile that for some reason is rebooting your phone at short periods of time. Consider contacting them and requesting their help. To me, it appears that they may have a configuration error without realizing it. Please be nice/respectful to them. I could be wrong. :-)

WRT you question about better hardware, I'd love to cause you to purchase a nice new phone, but to be honest, our devices all work in a very similar manner, so the problems should follow through any model SPA9xx or SPA5xx IP phone.


Regards,



Patrick

----------

sirahdigital Tue, 11/10/2009 - 01:18

Hi Patrick


I think we might have resolved this one - thanks so much for the advice and patience.


It does seem that the provisioning file from the hosting company was the cause in this instance.  They have changed the resync value from 10 to 3200 and the so far the problem seems to have gone away!


Hooray!


But now no excuse to get a shiny new IP phone!


Kind regards

Simon


PS I was very nice to them!

Patrick Born Thu, 11/12/2009 - 14:26

Hi Simon,


Thanks for the update. I'm glad to read that the issue appears to be resolved.


Regards,



Patrick

-----------

Actions

This Discussion

Related Content