FXO ports not working

Answered Question
Sep 28th, 2009
User Badges:

Hello,

We are in the process of deploying a UC520. We are trying use this with 4 pots lines connected to our FXO ports. I was wondering if I could get some help from the community on this one.


Problem is that the fxo lines don't work. We started with a default config, used the setup wizard in cca version 2.1 and did the basic config. We can make internal calls, but the external calls don't work. I am attached the debugs from a failed call. the debugs are the result of the "debug voice ccapi inout" command. If you look into the debugs, you will see that the called number is blank. I thought that this might have something to do with translation rules, but it didn't appear that the translation rules were wrong.


I am also attaching the config. This config file is the configuration as done by CCA after the initial setup wizard - nothing was changed.


Sometimes it works. It seems that we can reboot the router and it might work for a call or two after it was rebooted. So, it's very intermittent. I wasn't able to get it to work again and collect debugs on a successful call.


Also, there is a very long pause and then it rings and then it says that the number can't be reached. I can get the exact verbage if it matters.


Also, the inbound calls are consistently successful. Successful in that we call in and get the tone for the autoattendant.


Any assistance would be greatly appreciated. We are trying to get the customer to by smartnet so we can call it into the TAC and/or upgrade the CME/IOS/CUE. But, in the meantime we are trying to figure it out on our own.


Is it possible that there could be a hardware problem? Are there any configuration parameters related to an FXO port that could cause this? I always thought that FXO was pretty straight forward.


Thanks,

Ben

Correct Answer by Steven Smith about 7 years 10 months ago

In your dial plan on CCA, remove any of the dial patterns that mention 7 digit dialing and see if that helps.  The dial peer that was used is a 7 digit dial peer which doesn't sound like it will work for you.

Correct Answer by Marcos Hernandez about 7 years 10 months ago

Hi Ben,


I will look into your configuration in more detail, but what you describe seems to indicate that calls are probably being routed out of FXO ports that are not connected. Are all the FXO ports on the UC500 being used? If not, could you try configuring Trunk groups from the outbound dialplan settings?


Thanks,


Marcos

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Marcos Hernandez Mon, 09/28/2009 - 14:53
User Badges:
  • Blue, 1500 points or more

Hi Ben,


I will look into your configuration in more detail, but what you describe seems to indicate that calls are probably being routed out of FXO ports that are not connected. Are all the FXO ports on the UC500 being used? If not, could you try configuring Trunk groups from the outbound dialplan settings?


Thanks,


Marcos

Benjamin Waldon Mon, 09/28/2009 - 14:54
User Badges:

Thanks Marcos. I appreciate your help.


Yes, we did. We tried to modify the outbound dial plan to only include the two fxo ports that actually had lines connected to them. This didn't seem to help.

Steven DiStefano Mon, 09/28/2009 - 15:02
User Badges:
  • Blue, 1500 points or more

Hi Ben,


In the spirit of community, I share the following.  I have not checked your config, but configured this myself the ther day and I have 911:9911 routing out an FXO PSTN trunk Group I built.  I my case, I have it connected to a LAB AT&T Definity PBX, which is connected to the Cisco Campus, so when I dial 911, the Cisco security guy answers.  So I know its working.  This system I have also has a SIP Trunk, but I set the outgoing dial plan to Prefer the FXO, to see that the PSTN CLID is presented to the PSAP (and it is).


Maybe worth a try to check out the config?  Sometimes we miss one step or something (I do it all the time, cause I'm old; hence why I write it down)


https://www.myciscocommunity.com/docs/DOC-10701


You can use CCA 2.1 to do all this.


Steve DiStefano

Marcos Hernandez Mon, 09/28/2009 - 15:02
User Badges:
  • Blue, 1500 points or more

Hi Ben,


in the traces that you attached, there is a called number and a dial peer selection pointing to the FXO trunkgroup:


Sep 25 23:32:48.835: //37/9159B5DC805C/CCAPI/ccIFCallSetupRequestPrivate:
   Interface=0x84F084E4, Interface Type=6, Destination=, Mode=0x0,
   Call Params(Calling Number=115,(Calling Name=Jonny Q)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=503334079(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
   Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE, Outgoing Dial-peer=60, Call Count On=FALSE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=ALL_FXO, tg_label_flag=2, Application Call Id=)


Notice however how the number is 9 digits. Dial peer 60 is a 7 digit dial peer. What number did you try to dial?


Marcos

Benjamin Waldon Mon, 09/28/2009 - 15:07
User Badges:

Hi Marcos,

Yes, thanks for pointing that out. I guess I didn't see that the first time


I was trying to dial 5033394079. That's my cell number. I was attaching a 9 to it. Looks like the UC was dropping the 9 at the beginning and the nine in the middle, but not the 9 at the end.


Incidently, our phone provider requires us to dial the area code for local numbers.


I can probably figure it out, but how would I turn the dial peer into a 9 digit dial peer?


is there a place in CCA where we need to tell it that local calls include area code?

Correct Answer
Steven Smith Mon, 09/28/2009 - 15:14
User Badges:
  • Gold, 750 points or more

In your dial plan on CCA, remove any of the dial patterns that mention 7 digit dialing and see if that helps.  The dial peer that was used is a 7 digit dial peer which doesn't sound like it will work for you.

Benjamin Waldon Mon, 09/28/2009 - 16:14
User Badges:

Everyone has been really helpful with this. I am going to close this. Turns out, the customer reconfigured it one more time, going back to defaults and it's working now. I think the 7 digit dialing plan was definatley the problem..


Thanks,

Ben