Mobile Voice Access not working

Unanswered Question
Sep 29th, 2009

Hi Guys

I have configured mobile voice access for my client on CM6 with H323 gateway.

When I called in to the number configured from my mobile, I am getting invalid/reorder tone. From my desk phone (cisco), I will hear the call being answered but silence, and a prompt saying my call cannot be completed shortly.

When I do a trace in the gateway (debug call app vxml all), nothing is returned. I have tried reseting the mobile voice access services, reset the dial-peer, reconfigured the application (http://x.x.x.x:8080/ccmivr/pages/IVRMainpage.vxml)

Any help is appreciated.

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gogasca Thu, 10/01/2009 - 00:54

Call should match POTS dial-peer, from there invoke the vxml service

make sure MVA is pointing to Pub and service is up and running.

when you load the service in IOS you should see if ter mon is enabled if router is able to load the service or not to memory

make sure we in fact match incoming dial-peer

goranpilat Thu, 10/01/2009 - 01:21

Hi Gonzalo,

I have the exact same problem. The router seems to succeed in loading the script, but when I call the service in inbound dial-peer, I get the following error :

ep 30 14:52:11.268: //261//AFW_:/vapp_notify_play_done:

Sep 30 14:52:11.268: //261/AAE14F2A8037/VXML:/vxml_media_done:

CALL_ERROR; fail with vapp error 2, protocol_status_code=204

Sep 30 14:52:11.268: //261/AAE14F2A8037/VXML:/vxml_cancel_hotword:

Sep 30 14:52:11.268: //261/AAE14F2A8037/VXML:/vxml_error_badfetch_event:

CALL_ERROR; *** error.badfetch.http.204 event is thrown

Sep 30 14:52:11.268: //261/AAE14F2A8037/VXML:/vxml_event_proc:

: event=error.noresource status=0

Sep 30 14:52:11.268: //261/AAE14F2A8037/VXML:/vxml_expr_eval:

expr=(var _event='error.noresource')

Sep 30 14:52:11.268: //261/AAE14F2A8037/VXML:/vxml_jse_global_switch:

switch to scope(anonymous)

On NetPro I came across some similar posts which advise me to change localisation of this vxml gateway (because in .vxml file some fields are "null", but didn't manage to do that-couldn't find what the guy ment)..

Btw, is it possible to do mobile access on MGCP gateway (all I see is HOWTOs for H323)

Thanks in advance

Goran Pilat

sebastiandm Thu, 10/01/2009 - 02:36

Have you checked your service parameters are correct and MVA numbers match the gateway ? Also, can you confirm the vxml app is registered on the gateway ?

goranpilat Thu, 10/01/2009 - 03:02

hi,

I see the vxml script register to gateway (it is written by a router a second or so after I write the line service CCM http:.....)

What do you mean by "MVA numbers match the gateway"? I have the 1005 as MVA number and such dial peer on gateway (inbound pots and outbound voip to ccm).

application

service CCM http://10.1.200.21:8080/ccmivr/pages/IVRMainpage.vxml

dial-peer voice 9997 voip

destination-pattern 1005

session target ipv4:10.1.200.21

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 9998 pots

service ccm

incoming called-number 1005

no digit-strip

direct-inward-dial

The call is immediatelly dropped. If I leave out the service line on 9998 dial-peer, I can hear call manager answering to me The call cannont be completed as dialed...

Thanks for any advice

Regards

Goran Pilat

sebastiandm Fri, 10/02/2009 - 02:45

Hi,

You need to ensure your MVA settings in the service parameters in CUCM and the MVA number itself in CUCM corresponds to whats configured on your gateway ie digit manipulation etc..

Actions

This Discussion