Another OSPF tunneling question

Unanswered Question
Sep 29th, 2009

Hello all,

Thanks for all the advices on how to set up tunneling for ospf. In my test network, I used a switch to simulate a WAN sitting in between the two routers. I can ping every node on ospf networks without setting up static route in the routers and I guess that because the tunneling IP addresses are in the same subnet and they both connected to the switch. Should I connect to a WAN that I have no administrative privilege over, do I need to set up static route in the routers so that they would know which WAN gateways to use (i.e. 192.x.x.152 and 142.x.x.152 are interfaces of the WAN entry points for routers 4 and 5 respectively)? What should the ip routes be? Here're current config files:

hostname Router4

!

policy-map FQ

class class-default

fair-queue

!

interface Tunnel0

ip address 10.1.1.1 255.255.255.0

tunnel source GigabitEthernet0/0

tunnel destination 142.x.x.105

!

interface GigabitEthernet0/0

Description external WAN

ip address 192.x.x.104 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 instance 64 network manet

ospfv3 1 area 0 address-family ipv4 instance 64

service-policy output FQ

!

interface GigabitEthernet0/1

Description internal LAN

ip address 192.x.2.40 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 1 area 0 address-family ipv4 instance 64

!

router ospfv3 1

router-id 4.4.4.4

log-adjacency-changes

!

address-family ipv4

timers spf 1 2

router-id 4.4.4.4

exit-address-family

!

ip forward-protocol nd

--------------------

hostname Router5

!

policy-map FQ

class class-default

fair-queue

!

interface Tunnel0

ip address 10.1.1.2 255.255.255.0

tunnel source GigabitEthernet0/0

tunnel destination 142.x.x.105

!

interface GigabitEthernet0/0

Description external WAN

ip address 142.x.x.105 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 instance 64 network manet

ospfv3 1 area 0 address-family ipv4 instance 64

service-policy output FQ

!

interface GigabitEthernet0/1

Description internal LAN

ip address 192.x.4.40 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 1 area 0 address-family ipv4 instance 64

!

router ospfv3 1

router-id 5.5.5.5

log-adjacency-changes

!

address-family ipv4

timers spf 1 2

router-id 5.5.5.5

exit-address-family

!

ip forward-protocol nd

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
yagnesh_tel Tue, 09/29/2009 - 10:21

Hi Hugh,

One of the requirement for building GRE is that the tunnel destination address must be reachable from the interface other than tunnel itself. This is because if the tunnel destination is reached through the tunnel then there will be recursive routing and the tunnel will be brought down with error.

So you will require to specify how you will reach tunnel destination on both routers using static routes pointing towards WAN gateways.

For example on Router 4

ip route 142.x.x.105 255.255.255.255

Also be sure to not advertise these tunnel ends from other end using OSPF.

Actions

This Discussion