871w router lan connectivity - set up

Unanswered Question
Sep 29th, 2009
User Badges:

I think I may have found the correct forum here. Been trying forever to make good use of the router I purchased from Cisco market during CCNA class.(871w) I wiped the initial config , thinking I was good enough to do it by commands. Slick , huh? Well never been able to get SDM to work. Main reason seems to be VLANs and fact you can't put address on fe 0 to fe 3 ports. To be brief , I can open a terminal for commands log on to router and set an address on fe 4 , the wan port, and ping both ways to and from the laptop. Wish to do two things if I can get help. Set up VLANs so I can connect my local net. And reinstall SDM , which doesn't connect because there is no correct IP address for it. When I try to follow cisco manual / instructions it always directs towards configuration for switches regarding the VLANs and that is a whole different animal indeed.

Please anything may help, appreciate it. Thanks Doug M.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Lucien Avramov Tue, 09/29/2009 - 10:49
User Badges:
  • Red, 2250 points or more

Can you post the output of show run of your 871w and also tell me what subnet you want to use and on what interface you plugged your computer?



BeenyBoyz Wed, 09/30/2009 - 07:57
User Badges:

Okay , here is the output from the router as of now.


*****************************

Router#show run


Building configuration... Add an access list en


Current configuration : 1114 bytes

alias

!

version 12.4 Create com

no service pad

service timestamps debug datetime msec Configure the A

service timestamps log datetime msec

no service password-encryptionive Archiv

!t

hostname Router

!

boot-start-marker

boot-end-marker

!S

!

no aaa new-modely

!

resource policy

!

ip subnet-zero

ip cefy syst

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.0 192.168.0.10 Define a login banner

ip dhcp excluded-address 172.0.1.0

network 192.168.0.0 255.255.255.0

boot

!

ip dhcp pool handoutsot parameters

network 172.0.0.0 255.255.0.0

bridge

!

!

no ip domain lookupoup.

!

!

!

!

!

!

!

!

interface FastEthernet0 Adjust syste

!b

interface FastEthernet1

!

interface FastEthernet2

call

!

interface FastEthernet3ure Call parameters

!

interface FastEthernet4

ip address 192.168.0.1 255.255.255.0 call history mib parameters

duplex auto

speed auto

!

interface Dot11Radio0 Global C

no ip addressn subcom

station-role root

!

interface Vlan1

ip address 172.0.1.10 255.255.0.0

!

ip classless

!

no ip http server

no ip http secure-server

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end


Router#

**********************

Note when I run "show vlans" it says no virtual vlans configured.

I want a wired connection to port(s) fe 0 to fe 3 but no vlans and no ip address can be set there, I have ip address for vlan 1 and ip address on fe 04 the wan port. Am connected to wan port (and console cable) to my laptop and can ping on the lan interface fe 4. Ips are not important to me as I can change it around anyway. Same for port numbers.

Just want to connect via fe 0 -3 to local server for now. Then I'll work on my internet connection and wireless network . Can't seem to get the sub-interface for fe 0 -3 going because no vlans to put a ip number on. Okay?

In case it is needed let you know I have no files in flash except the IOS 124-4.t7.bin .

Copied and then deleted them.

Hope the show run pasting wasn't too bad , and you can read it. If there is a better way to format , let me know I'll do again. Used copy / paste right to this window. Thanks for your answering back! Doug.


johnnylingo Tue, 09/29/2009 - 19:26
User Badges:
  • Bronze, 100 points or more

Check that you have "ip http server" in the config and have a username and password setup. Also you should be plugging a PC in to ports Fe0-3 (which will be in VLAN1 by default), then using the VLAN1 interface to access SDM.

BeenyBoyz Wed, 09/30/2009 - 08:05
User Badges:

I did try to reset SDM and set http server to secure but router is more misconfigured than that I believe. Those are the resets for SDM , but when I ran that configuration I still do not have any ip address on fe 0 through fe 3 . I did get an idea , what about if I used fe04 for the 10.10.10.1 address it looks for during set up? It may find the address and work like that?? Thanks- Doug.

Lucien Avramov Wed, 09/30/2009 - 08:28
User Badges:
  • Red, 2250 points or more

There are a few things that are misconfigured on the show run you attached.


ip http server was missing but also the login local and the username privilege 15.


Make sure you follow the steps here:


The following example shows a configuration that contains the CLI commands Cisco SDM requires in order to operate.


hostname yourname

!

logging buffered 51200 warnings

!

username cisco privilege 15 secret 0 cisco

!

ip domain-name yourdomain.com

!

interface FastEthernet0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-10/100 Ethernet$

ip address 10.10.10.1 255.255.255.248

description PC must be on the same subnet as this interface

no shutdown

!

ip http server

ip http secure-server

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

!

line vty 0 4

privilege level 15

login local

transport input telnet

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet

transport input telnet ssh



http://www.cisco.com/en/US/docs/routers/access/cisco_router_and_security_device_manager/software/release/notes/SDMr25.html

BeenyBoyz Wed, 09/30/2009 - 08:49
User Badges:

Okay. A bit confused on why to keep setting up SDM though if I can not enter the commands to get the lines that says

************************

" interface FastEthernet0

description ?????????????

ip address 10.10.10.1 255.255.255.248

description PC must be on the same subnet as the interface

no shut"

*******************************

All the other lines I can configure , secure http server , telnet , login passwords etc.

Cisco has instructions to "reset SDM" for connecting but doesn't include putting IP on the fe 0 . That's where I am lost. Thanks for the link thought , there is lots to look at there. Mean time I'll set up sdm way I had done it before and paste the output of show run again so you can see what I mean. Thanks.

BeenyBoyz Wed, 09/30/2009 - 09:18
User Badges:

Here is the config with reset SDM .

******************************




Notice I changed my Fe 4 ip to try to connect sdm that way. Doesn't seem to like it. SDM install tries to connect and then says error 404 in browser. Also do you see where i do not have an IP address on fe-0 like your config did? That's where sdm want to connect.

**********************************

Building configuration...


Current configuration : 3005 bytes

!

version 12.4

no service pad

service timestamps debug dat

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip subnet-zero

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.0 192.168.0.10

ip dhcp excluded-address 172.0.1.0 172.0.1.10

ip dhcp excluded-address 10.10.10.0 10.10.10.10

ip dhcp excluded-address 10.10.10.0 10.10.10.1

!

ip dhcp pool wireroute

network 192.168.0.0 255.255.255.0

!

ip dhcp pool handouts

network 10.10.10.0 255.255.255.248

!

!

no ip domain lookup

!

!

crypto pki trustpoint TP-self-signed-3962786491

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3962786491

revocation-check none

rsakeypair TP-self-signed-

!

!

crypto pki certificate chain TP-self-signed-

certificate self-signed


quit

username beeny privilege 15 password 0 cisco

!

!

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

ip address 10.10.10.1 255.255.255.248

duplex auto

speed auto

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0

54.0

station-role root

!

interface Vlan1

ip address 172.0.1.10 255.255.0.0

!

ip classless

!

ip http server

ip http authentication local

ip http secure-server

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end


Router#

Does any of this make sense or should I give up on it!

iyde Sat, 10/03/2009 - 03:17
User Badges:
  • Silver, 250 points or more

FastEthernet 0, 1, 2 and 3 are switchports, i.e. layer 2 ports. As in all (?) Cisco switches, layer 2 switchport by default are in VLAN1, the default VLAN. This means that if you try to connect to the rotuer via FastEthernet 0-3 you'll have to do the matching IP configuration under interface VLAN1, which in your example is IP net 172.0.0.0/16 and IP address 172.0.1.10

So try set your PC IP address to something in the 172.0.0.0/16 and then connect to 172.0.1.10

HTH

BeenyBoyz Mon, 10/05/2009 - 10:50
User Badges:

Hi there!

Thanks for the info. It does seem to be that simple. Am trying it out , give me a bit if time and I'll let you know if it works. Thanks again for posting reply! I may not get right back to you for a day or so though.

Actions

This Discussion