Cisco Class Based QoS Monitoring issue

Unanswered Question
Sep 30th, 2009

While monitoring CBQoS policies, we are facing a peculiar issue in some of the routers.

The issue is when you change the values on the policy applied on the interface of the router and when you do QoS policy update on the Analyzer, we are getting message saying that "no policy applied" even though the Analyzer was retrieving the CBQoS data before on the same interface.

Only way we can retrieve the policy again on the Analyzer is only by rebooting the router. It is not coming on all the routers. We are facing this issue in 2811.

Any idea why it is so?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Lucien Avramov Wed, 09/30/2009 - 06:43

This sounds like a bug issue.

What code are you running? I presume all your routers affected run the same IOS code?

Do you mind sharing your configuration and tell me which interface this happens to? Is it the same one interface for all your routers?

Is it possible to run a debug snmp packet on the router and poll only this MIB? (I dont want to cause you an outtage by turning the debugs on) Wed, 09/30/2009 - 10:02

I have attached the show run config, the network setup and the SNMP debug from the product. The serverout file which i have attached contains the SNMP information when we do QoS get

Lucien Avramov Wed, 09/30/2009 - 12:55

Need more data:

I need a show version output and the debug from the router itself. The debug of the product is not helpful. Wed, 09/30/2009 - 23:07

Hi Lavramov,

Thanks for your reply. Can you advise us how to take a snmp debug dump while polling the MIB from the product. Any commands?


Raj Thu, 10/08/2009 - 00:58

Hi Lavamov,

We tried debug snmp packet command on the router. But it does not display anything. When we check sh debugging, it says SNMP debugging is on. Is there anyother way we can get the SNMP debug print out?

He also verified SNMP requests has been sent to router, when he tried the command.


Raj Mon, 10/12/2009 - 00:54

Hi Lavramov,

I have tried in our environment. The command does not seem to be giving any outputs.

debug snmp packet

But in our environment we can effectively reproduce the same issue for nested policies.

Can you join a webex meeting session to troubleshoot the issue?




This Discussion