Gigabyte uplink speed

Unanswered Question
Sep 30th, 2009
User Badges:

I have 2 Catalyst 2960 switches with gigabyte ports on them. Since the gigabyte ports are being used to connect the 2 switches I hard coded the ports on both sides with “speed 1000”. When I do this the ports do not come up. I have tried both Cat5e and Cat6 cables. If I take the “speed 1000” off on one side the link comes up. As a best practice I always hard code the ports that connect my switches. Not sure what I am missing here. Any advice would be great.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Wed, 09/30/2009 - 13:45
User Badges:
  • Purple, 4500 points or more

You are not using the correct crossover cable between the switches . You have auto mdix configured on the ports which lets you use either a crossover or straight thru. The function only works if the speed and duplex is set as auto otherwise the port will show not connect. If you feel you need to hardcode then you will have to use cat 5 crossover cable . Between cisco gear auto usually works fine and is fact reccomended for gig connections.


Cisco Infrastructure Port Recommendation


The configuration of autonegotiation is much more critical in a GE environment than in a 10/100 Mbps environment. Only disable autonegotiation in these situations:


*


On switch ports that attach to devices that are not able to support negotiation

where connectivity issues arise from interoperability issues


Enable Gigabit negotiation on all switch-to-switch links and, generally, on all GE devices. The default value on Gigabit interfaces is autonegotiation.

Cisco Access Port Recommendations


Since FLPs can vary between vendors, you must look at switch-to-server connections on a case-by-case basis. Cisco customers have encountered some issues with Gigabit negotiation on Sun, HP, and IBM servers. Have all devices use the Gigabit autonegotiation unless the NIC vendor specifically states otherwise.

Actions

This Discussion