SPA2102 FW 5.2.10 NAT Keep Alive Bug

Unanswered Question
Sep 30th, 2009

I noticed that the behaviour of the NAT_Keep_Alive_Msg sent by the device changed with firmware 5.2.10.

Prior to 5.2.10 the keep alive messages did not contain a 'Contact'-Header. Changing the message type from $NOTICE to $REGISTER worked fine with Asterisk.

Now the messages do contain a 'Contact'-Header, but with ";expire=0" attached to the end. When the message type is set to $REGISTER this causes Asterisk to UNregister the client, what surely is not the sense of a keep alive message! Guess what happend after updating some of my customers... not really worth a smile! :-(

Assuming that this is a bug and will hopefully be fixed with the next release I strongly suggest to stay with the default value of $NOTICE when there is no real need to change it. To the development team I suggest to interpret the $REGISTER type to send out just an ordinary REGISTER message as is normally sent before expiry, or simply keep the old behaviour as it worked out with Asterisk.

Feedback to this comment is strongly encouraged :-)

Eik Rentzow

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Patrick Born Wed, 09/30/2009 - 15:21

Hi Eik,

Thanks for bringing this to our attention. We really want our products to work well with Asterisk and other 3rd-party call control.

I have shared your input with Product Marketing, Escalation Engineering, and Product Engineering. I'll report back as soon as I am able.




Patrick Born Thu, 10/01/2009 - 16:22

Hi Eik,

The behavior was changed because of: SIP NOTIFY keep alive messages does not have Contact header

The current fix makes sure that both the Event and Contact headers are present in NOTIFY keep alive messages

Engineering responded with, "For the keepalive, the default is $NOTIFY.  ... ... we don't recommend using $REGISTER for the keepalive."

I have located and attached the release notes for this version of firmware.




aviduser21 Mon, 02/01/2010 - 15:13

Has there been a fix implemented or scheduled for the $REGISTER keep alive?  The expires=0 is tough to overcome.  Any workarounds available?

Thanks -



This Discussion