RV082 - Newest Firmware - V1 Hardware? - Slow DNS Lookups

Unanswered Question
Oct 1st, 2009

I was running firmware 1.3.98-tm - and everything seemed to be working fine (no complaints from me - things ripped)

Serial Number :      DEZ00610370x

Firmware version :      1.3.98-tm (Jun 20 2008   18:37:29)

CPU :    Intel IXP425-533

Not sure if I have V1 or V2 hardware - or how to tell.

But that said - I upgraded to 2.0.0.19-tm yesterday. Upgrade went smoothly. All settings seemed to be retained after upgrade.

It now seems that DNS lookups intermittently fail - and/or are definitely slower.

I am assuming it is the DNS lookup that is taking more time (or failing) - as I use a product from Firetrust called Mailwasher Professional - which every 15 minutes - connects to all of my POP3 servers (about 8 of them - simultaneously) - and attempts to download a portion of each message for some Bayesian analysis. During the initial connection attempts - multiple failures occur with multiple e-mail accounts - indicating messages like "No Such Host". On a retries - it either works - or - produces the same error. What is further weird - when I set the Mailwasheer product to check each of the accounts "serially" - one by one - no errors occur. Problem seems to evidence itself only when router is presented with multiple lookups. The same behavior is evidenced within Firefox - when checking for updates to my extensions(much slower with the new firmware)

I backed out the firmware upgrade - and every is now working satisfactorily. Re-apply the new firmware - and the DNS weirdness returns.

Anyone out there having similar problems - or have any ideas?

I like running with the latest firmware - but I just can't live with this level of performance degradation.

Regards,

Doug

Environment:

Windows® Vista® Ultimate SP2 64-bit {EN}
Intel® Core™2 Quad Q9400 / Memory: 4GB

Intel® 82562V-2 10/100 Network Connection

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Carr Thu, 10/01/2009 - 13:50

Typically after a firmware upgrade, you would need to do a factory reset of the router and reload the configurations, either manually or back up the configuration to a pc and reload it after the factory reset.  Try that and see if the router is working better for you.

mrfreeze@mrfree... Thu, 10/01/2009 - 14:31

Thanks for the suggestion - Problem is still present with fresh default factory settings.

Regards,

Doug

Te-Kai Liu Thu, 10/01/2009 - 14:33

You might need to let the DHCP clients know by rebooting the router or the clients.

mrfreeze@mrfree... Thu, 10/01/2009 - 14:37

Adapter was released and renewed - with same problem.

Thanks guys for all your suggestions - (hey keep em coming - love to troubleshoot).

Regards,

Doug

Te-Kai Liu Thu, 10/01/2009 - 14:51

If the DNS Server configuration on RV082 is pointing to the ISP's DNS Server, as already done according to your screenshot, we have to assume that the issue might be the ISP's DNS Server. Could you check the current DNS Server used by the client computers? On Windows, you could do

ipconfig /all

David Carr Thu, 10/01/2009 - 14:57

Try pointing to these two dns servers in the DHCP TAB.  4.2.2.1 and 4.2.2.2.  These are well known dns servers that are very reliable.

mrfreeze@mrfree... Thu, 10/01/2009 - 15:20

ipconfig on the client computer reports (under both versions of the firmware) - that the DNS Servers are my ISP's :

167.206.254.1  167.206.254.2

When changing the DNS Server to 4.2.2.1 and 4.2.2.2  - ipconfig (after release and renew) - shows them to be:

4.2.2.1 and 4.2.2.2.

Even with these new DNS servers - the behaviour remains the same when using the new firmware.

Backout to the old firmware - and problem goes away - with either of the DNS servers chosen (mine or yours) ????

Thanks and Regards,

Doug

David Carr Fri, 10/02/2009 - 06:52

When you upgraded the firmware did you do a factory reset and reload your configurations, or just did the firmware upgrade and let it run like that?

mrfreeze@mrfree... Fri, 10/02/2009 - 07:43

I've done both - as well as tested from a fresh factory reset and the default config.

If it wasn't for the fact that the problem does not manifest itself - after rolling back to the old firmware - I would not be so convinced that there was something wrong with the new firmware (or with my particular router and this firmware and/or how my particular operating system interacts with the new firmware). But the common thing here is - the introduction of the new firmware - because it is only then - when this problem rears its ugly head.

I'm sticking with the old firmware - just thought that you/your engineering group would want to know about my experience. I am here (monitoring this post) and willing to try anything else you/your engineering group has in mind.

I realize the firmware is still relatively new - and perhaps many people have not upgraded yet - or just may not have noticed the problem yet. If there is really a problem with the firmware - then I would expect many more posts to come.

I have seen some posts elsewhere - mainly complaining about an unspecified problems after upgrading - and then not being able to roll back. (I think the newer HW version - does not allow you to roll back - which should be a warning to anyone planning to upgrade to this new firmware).

Highest Regards and Thanks,

Doug

David Carr Fri, 10/02/2009 - 07:59

Yeah, i haven't heard many flaws with the new firmware, but it is relatively new.  But yeah, thank you for your post and i will forward the message on the rv082.

landgroupidaho Tue, 10/27/2009 - 15:28

I was starting to think our ISP had an issue or I was losing my mind.  I've been trying to solve the same problem, and didn't think it could be the router because I wasn't seeing anybody else complain.  But now I've checked everything else and that's the only thing left so I bet going back to the old firmware will fix this issue for us as well.  Another interesting thing in this new firmware I noticed is that when doing line tests and smokeping tests from dslreports.com, it says that 90% of the ping traffic is lost.  If I turn off the firewall then it's fine.  Definately something funky going on with the Version 2 firmware and V1 hardware.

rjgebis@hotmail.com Thu, 10/29/2009 - 07:15

This is related to other issue that I reported as well on RV082 (2.0.0.19) as well RV016 (3.0.0.19 firmware) but I did not hear anything about it?

It is related to general slow down of all traffic on both routers when multicast is going trough it.

Also looks like there is a DNS missing on RV016 under DHCP like it is under RV082.

David Carr Fri, 10/30/2009 - 08:11

I have a rv016 that i looked at the DHCP tab and there is a required DNS section for pc's receiving DHCP from the router.  If you are not able to see that, I would change your browser you are using and see if the option is there.  But by default under that firmware it does have the DNS option there.

rjgebis@hotmail.com Fri, 10/30/2009 - 22:17

David, sorry for not being clear enough on my initial post. What I meant to say is missing "DNS Local Database" section that exists on RV082 but not on RV016. Here is screen shot from RV082 that I am talking about.

http://www.dslreports.com/r0/download/1333710.thumb600~e97a3c7414dfb08b18df39b77a0c6e2c/RV082-DNS-LocalDatabase.png/thumb.jpg

Any ideas why does not exists on RV016. I just upgraded from RV082 to RV016. Could this be added back?

Better yet. Why have DNS Local Database if you could reuse "name" when assigning MAC to IP? Unless there is some technical reason than " DNS Local Database" section would be just fine

bethingt Sun, 11/01/2009 - 08:41

I doubled checked the admin guide for the RV016 to make sure and the DNS Local Database is not an option avaliable on the RV016. As to why I am not sure I will try to find out some more information for you.

Te-Kai Liu Sun, 11/01/2009 - 09:12

I can confirm that DNS Local Database feature is not avaliable on the RV016. We will look into supporting this feature on RV016 in the future.

Te-Kai Liu Thu, 10/01/2009 - 14:19

You could try configuring the DNS Server (in the Setup>DHCP page) to point to your ISP's DNS Servers so RV082 will not get in the way of internet-bound DNS queries.

Hardware version (e.g. RV082 v2) is shown on the product label typically located at the rear or bottom of the product.

mrfreeze@mrfree... Thu, 10/01/2009 - 14:34

Just tried that - but problem still ocurrs ??? Somehow the "router" is still "in the way".

Regards,

Doug


Network Setting Status
LAN                  IP :192.168.1.1
WAN1 IP :69.113.140.xxx          
WAN2 IP :0.0.0.0          
Mode :Gateway
DNS (WAN1) :
DNS (WAN2) :
167.206.254.2      167.206.254.1     
 
DDNS(WAN1   |   WAN2)                 :Off       |       Off
DMZ                  Host :Disabled


DNS

DNS Server                    (Required) 1:

.                    .                    .                   
2:
.                    .                    .                   
makotocole5 Wed, 04/11/2012 - 13:35

Cisco,

Is there any movement on this?  I am experincing the same issue.  There is no way that i know of to downgrade vesion 2.0 firmware back to version 1.0.  I am using a RV082 V02 hardware model.

DNS queries are very slow with the latest firmware 2.0.2.01-tm

dondersconsulting Sun, 07/01/2012 - 10:47

Doubtful Cisco will be repairing the old firmwares.  I think they just programmed some stuff in there to parallel the v3 hardware's newest firmware, and it is stressing out the CPU/RAM in the older v2, v1.1, v1.0 units.   I already gave up with my most demanding couple clients and upgraded them to the v3 hardware.  The v3 seems faster and the GUI is FAR better since all the IP info is a single field instead of one for each octet - lets you copy/paste and overall just faster to configure.  Sucks to drop another $300 when yours should work, but it's still quite cheap considering you are saving yourself from buying a $750 Cisco/Sonicwall/etc router.

With that said, I'm trying the downgrade to v1.3.98 on two RV082 v1.0 units and will let you know if problems continue.  I also have a v2 unit but will have to check that first.  I think the v2 firmware came out with the v2 hardware, and it won't run with v1.3.98 firmware - is that what you were getting at?

Actions

This Discussion