isdn incoming call strange issue

Unanswered Question
Oct 2nd, 2009

Hi to all,

i'm trying ro configure a 2801 with 2 bri interface for 2 isdn lines but the strange thing is that i can make call from an ip phone but i cannot receive call from external phones.

The phone begin to ring but in the same istant on the other side the call drop... and the phone continue to ring until i answer to the call.

I have checked everything and all seems ok, someone can help me? All is managed by call manager 4.1.3 and on the other site of this customer all is working fine,this is a new installation.

Best regards,

Carlo S.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
blatkinson Fri, 10/02/2009 - 02:54

sounds like a codec mismatch. Maybe only 722 is running on the phones? Try adding 722 to that dialpeer as a quick test or check locations/regions config on CM.

voice class codec 1

codec preference 1 g722

codec preference 1 g711ulaw

codec preference 2 g729br8

dial-peer voice 9000 voip

preference 1

destination-pattern 9.......

voice-class codec 1

You may need on the POTS dialpeer now that I read your message again.

daysleeper Fri, 10/02/2009 - 04:25

mmh i don't think the problem is the codec because outgoing call work fine, i noticed the problem occur only when i call from cellular network and not from fixed line....from cellular network i ear a tone of error, but from fixed line after some seconds of waiting the call work fine.

Paolo Bevilacqua Fri, 10/02/2009 - 04:29

It can indeed be a codec problem.

In any case take debug isdn q931 for one good and one failed call, and compare.

Wilson Samuel Fri, 10/02/2009 - 04:57

Hi Paolo,

Whats the best debug command to begin debbugging any Voice Call (ISDN PRI/BRI and POTS/FXO)?

I have tried "debug voice ccapi" and "debug voice ccapi inout" however none of the commands ever display the calling number n Called Number, which as per the Cisco Wiki should get displayed, am I missing something here?

http://docwiki.cisco.com/wiki/Enhanced_Debug_Command_Sample_Output_Examples

Regards

Sam Wilson

Paolo Bevilacqua Fri, 10/02/2009 - 05:00

debug isdn q931, and debug vpm signal, respectively.

If you understand the logic of telephony, other debugs are rarely needed.

Wilson Samuel Fri, 10/02/2009 - 05:28

Thanks Paulo, I will definitly keep your advice. Also any word on why I cant see the Calling and Called Numbers on the debug voice ccapi inout?

Regards

Sam Wilson

Paolo Bevilacqua Fri, 10/02/2009 - 05:32

Because telco is not sending them.

May I ask you a courtesy, please refrain to rate my posts unless you see them to be worth a 5 as I always strive for them to be.

blatkinson Fri, 10/02/2009 - 18:18

ok, I see what you mean about the direction of the calls and the codec.

I'm thinking it is the q.931 setup message too.

under debug isdn q.931, what is your transfer capability?

If it doesn't equal 'Speech' there's your problem.

You should see 'CCITT Transfer Capability = Speech'

I remember seeing 'Unrestricted Digital' on some calls for a T1 I was turning up.

Here is how I fixed it:

interface Serial0/0/0:23

isdn incoming-voice voice

This occured on (C2800NM-ADVENTERPRISEK9-M), Version 12.4(15)T7 IOS.

I think I had tried another router with this same T1 and didn't have the problem, but that router was on a later T train release.

daysleeper Sat, 10/03/2009 - 01:47

The problem is solved...it was generated by did configured on bri interface!

It was the my first voice configuration and i don't know about did...now i think i will remember this for very long time!

Actions

This Discussion