Access Ports into Routed Ports

Unanswered Question
Oct 2nd, 2009

Dear Expert, I have Cisco 877 series Router, this type of router has 1 ADSL WAN port and 4 Ethernet LAN ports. The device will be connecting into the SHDSL circuit. It cannot use the ADSL WAN port since the SHDSL circuit is using Ethernet ports. Instead I will be using the LAN Ethernet ports (int Fa0) as WAN.

The said router can do the VLAN mapping and can do several VLANS. How can I used the LAN ethernet ports as WAN port for this case.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Giuseppe Larosa Sat, 10/03/2009 - 01:33

Hello Carlos,

you need to create a second vlan

conf t

vlan 2

assigns the port that connect to SHDSL to vlan2

int fas0


switchport mode access

switchport access vlan 2

! configure SVI vlan2 as your WAN interface

interface Vlan2

Desc WAN

ip address x.x.x.x


ip address dhcp

no shut

ip nat outside

other ports will be in vlan1 that is your internal subnet

int vlan1

ip address

no shut

ip nat inside


ip nat source inside list 1 int vlan2 overload

access-list 1 permit

Hope to help



This Discussion