using microsoft exchange with ssl vpn

Unanswered Question
Oct 3rd, 2009

i need to use microsoft exchange mails(not OWA) & also mircosoft office communicator via our ssl vpn setup.

When i try to connect to MS Exchange from vpn the main opening instance of exchange outlook just hangs in there & OC cant connect.

Any help towards enabling this will be appreciated.

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
auraza Thu, 10/08/2009 - 13:59

Are you using Clientless SSLVPN or AnyConnect (SVC)? Also, are you using a router or ASA as the WebVPN server?

suthomas1 Thu, 10/08/2009 - 21:39

We use both SVC & WebVPN on an ASA 5520 with ver 8.0.

I have tried making exchange/OC work with both clientless or svc, but doesnt seem to be happening.

Appreciate your assistance!

auraza Fri, 10/09/2009 - 05:41

As for exchange, I am assuming you're using outlook, in which case you would be using the SVC (AnyConnect) client. What error message do you get?

If you are using clientless then you are most likely using OWA, which should work as well - what is the problem you are experiencing - do you get the auth prompt? Does it get past a certain point and then fail?

suthomas1 Fri, 10/09/2009 - 20:50

Thats correct, am using Microsoft Outlook.

if i try to open Outlook after connecting to SVC, it doesnt open up & hangs in there with opening template.& i have to terminate it.& when on SVC, my Microsoft OC also gets disconnected.

If i connect to SVC after having the outlook completely opened & then try to send/receive an email, error says"The connection to MS Outlook is not available,Outlook must be connected/online to complete this action"

Is there any restriction that MS Outlook can only be used with SVC & not with Clientless.

Thanks.

auraza Sat, 10/10/2009 - 05:28

Well clientless will only allow OWA to work, as it is only the browser that is connected - you can't use any applications with it unless you use smart tunnels.

As for SVC, please read the following article and make the changes to the registry and see if it works:

http://support.microsoft.com/kb/244474

See if that also fixes the OC. If not, then on the ASA, please remove SIP inspection under the policy-map global_policy.

PS. please rate this post.

suthomas1 Sun, 10/11/2009 - 08:26

Thanks for your response. I will check these out.

Any suggestions on how to enable smart tunnels to use certain applications like sharedrive & other websites via clientless.

Btw, is there any way to capture the packets moving thru VPN. i tried this but it only captures based on the main vpn ip rather than individual sessions.

Thanks!

suthomas1 Thu, 10/15/2009 - 22:31

i tried removing from policy map but OC still doesnt comeup.

Any other things i need to check for this.

Thanks!

trippi Mon, 10/19/2009 - 12:15

Is your DNS setup correctly?

For example on the VPN setup, do u have your group pointing to your internal DNS servers?

suthomas1 Tue, 10/20/2009 - 05:57

Thanks everyone for the help.i got resolved, turned out to be a route issue of an intermediate device which was not being managed by us.

Appreciate all of your help!

Actions

This Discussion