Cisco 2811 + SFE2000P

Unanswered Question
Oct 4th, 2009
User Badges:

My setup


  1. Cisco 2811 ISR
  2. Linksys SFE2000P
  3. Cisco 7940 IP Phone


I have created 3 VLANs for this setup

VLAN 2 - Voice

VLAN 3 - Data

VLAN 10 - Management


The Cisco 2811 ISR connects to the SFE2000P via the FA0/0 port. Subinterface has been created on the cisco router and trunk interface configured on the linksys switch.


I have also created two DHCP pool for my setup. Voice network offering 10.x.x.x address and Data network offering 192.168.x.x addresses.


If I configure the switchports on the SFE2000P as an Access only port, the setup works prefectly. Configured switchport for Access only PVID set as 3, the laptop that I plug into the switchport is able to get a data ip address range. This also works for a phone if I set the PVID as 2.


However my aim is to be able to run 2 VLAN on 1 switchport, so I can utilise the the PC Port at the back of the phone. Can someone please help if I should tagged or untagged whichever VLANs and set the PVID to which VLAN.


I have configured it as VLAN 2 tagged and VLAN 3 untagged and set PVID to 3. Switchport mode is General however both my PC and Phone are getting the 192.168.x.x address which is not what I want.


Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
Loading.
Glenn Quesenberry Wed, 10/07/2009 - 13:41
User Badges:
  • Cisco Employee,

Steven,

     Have you tried setting the switchports on the SFE to "General" and assigning membership to both VLANs you want to access?

steven.t27 Wed, 10/07/2009 - 18:39
User Badges:

Glenn


Thanks for your response.


On the 2811 I have created subinterfaces FA0/0.2 (Voice) and FA0/0.3 (Data). The trunk goes from FA0/0 of the Cisco 2811 to port 24 of the Linksys SFE2000P switch. On port 24 of the SFE2000P switch I have configure it as a Trunk with both Voice and Data vlan Tagged.


I have configure the switch port where I plug in my phone and PC as General mode, Voice vlan Tagged and Data vlan Untagged and the PVID of the switchport is vlan 3 (Data).


However this is still not working.


Any other ideas?

David Hornstein Thu, 10/08/2009 - 06:43
User Badges:
  • Gold, 750 points or more

Hi  Steven,


The native VLAN on the SFE2000P is VLAN 0ne. I have no idea why you are not using VLAN1, but that's your prerogative.  :)


  So I guess you must have setup VLAN tagging from the 2811 so that VLAN2 and VLAN3 are setup as tagged VLANs going to the SFE2000P.


On the SFE2000P,   switch port 24 (uplink)  is set for vlan1 (native VLAN untagged by default) and VLAN2 and 3 setup at tagged.


On say,  switch port x on the SFE2000P, I would set,  as Glenn suggested,  the port to general mode with data VLAN 2 being untagged and voice  vlan3 being tagged.


On the 7900 phone, I would go into settings, unlock the phone with the keypad command **#  and find the setting to set the management vlan of the phone to vlan3.  Once that is done it should try to DHCP from the voice VLAN.


Don't have a 7900 phone in front of me to recall the exact steps to set the management vlan of the phone to vlan 3.  But it should not be hard to find.


It should be pretty simple, done this before on my SGE2000P and SRW series switch, but SFE2000P will work exactly like my SGE2000P.  If i can do it anyone can do it.


Have fun


regards Dave

Glenn Quesenberry Thu, 10/08/2009 - 06:43
User Badges:
  • Cisco Employee,

Steven,

     Any specific reason why you created two subinterfaces on the 2811?  Just wondering why that port wasn't just configured as a Trunk port, then any VLAN information would be passed through by default to the SFE switch.  Have you tried it that way without subinterfaces and just a a switch to switch Trunk port (on both the 2811 and the SFE?  Then on the SFE, try making any phone switch port as "general" and all traffic untagged.

     Also, you know the issue with support that you have implementing this is that the 2811 is a TAC supported switch and the SFE is a Small Business Support Switch so you will have two support resources to contact here to troubleshoot.  This is one of the reasons we typically try to steer partners away from this type of "hybrid" solution.  With that said, if my input doesn't work, I would then have to suggest you contact TAC regarding the 2811 and then the SBSC after TAC has helped you confirm that config.


Best Regards,

steven.t27 Tue, 07/06/2010 - 02:46
User Badges:

My solution to this debacle is to get a 4ESW wic card for the 2811 and establish a trunk from the router to the switch instead of connecting it via the gig port

Gaven Mankabane Thu, 03/14/2013 - 12:40
User Badges:

Hi steven.t27



Did you ever manage to resolve the issue with the Linksys SFE2000P.

I am currently working with the Linksys SFE2000P and experienced the same issue. I upgraded the firmware to the latest and I am not using vlan1 for data. I created another vlan for data and I was able to register my ip phone on my voice vlan and the pc on the data vlan.

Tom Watts Thu, 03/14/2013 - 14:02
User Badges:
  • Green, 3000 points or more

Hi Gaven, I've had some success with getting the two to work together. It's actually really bizarre. To the best of my recollection, the switch port mode needs to be general with ingress filtering disabled. The 2811 encapsulation type for the sub interface must be dot1q.


The switch port configuration should be something like general mode 1u, 2t, 3t, 4t etc, whatever your vlan IDs are.


I feel like there is something else to make note of but I can't remember at this time.



-Tom
Please mark answered for helpful posts

Actions

This Discussion

Related Content