CCA 2.1: Device Properties, User/Pass Java Error and SPA5x5 Phone Load for UC520 procedure

Unanswered Question
Oct 1st, 2009

Tried on 2 different pcs - both Vista Business 32-bit.

Click on Device Properties, Users and Passwords.

Get an immediate pop up with error. See attached jpg.

If you go ahead into & change password for existing user & click Apply or Ok, you get java.lang.NullPointerException.

Message was edited by: Steve DiStefano  Edited title to be more specific and easy to find and search

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)

I'll throw my two cents in this thread as well, just for fun.

I was just doing an upgrade of a two or three month old system to the newest 7.1.3 support pack using CCA 2.1. I noticed the following:

-When going into the upgrade screen, it was never able to display the phone load information, and the logs were full of exceptions as it tried to load the info. I went ahead with the upgrade anyway, and it went ok, but i don't think it upgraded any phone loads. at least i didnt see any of the phones upgrade (524SGs) and i was pretty sure the release notes showed an update.

-At the very end of the upgrade process (not sure where exactly) my laptop BSOD'd and rebooted. this has happened to me in the past with another version of CCA as well, don't remember the version. haven't noticed it recently. I was using the most current version of Java as well (just updated it prior). This issue REALLY bugs me.

Joseph Chambers Thu, 10/01/2009 - 17:30

I was going from 7.1.1 to 7.1.3.

I selected to upgrade CME & IOS only.  While there was field to select phone fw to upgrade, it was blank so don't know if it actually upgraded the phone fw.

Also, when upgrade was complete, it said it was going to wait 1 minutes to reload, but it never did.  I had telnet session open & it never reloaded.  I had to reload from CLI.

Saurabh Verma Fri, 10/02/2009 - 09:47

I've posted the question to CCA engineering team ... will forward their response as soon as I hear back.



Saurabh Verma Fri, 10/02/2009 - 11:05

The users/password issue that you ran into is a known issue in CCA and will be fixed in the maintenance release 2.1.1 due later this month.



Steven DiStefano Sun, 10/04/2009 - 19:05

UPDATE AND WORKAROUND for UC520 Upgrade to run SPA5x5 phones::::::

When upgrading to the UC520 SW Pack for SBCS 1.6 to run the new SPA5xx phones and use the new Phone Load Manager, I did run into an issue that you should be aware of.  I think we should update our admin guide perhaps (I wll send this thread to the DOC team).

Since the SW pack will contain new phone loads, you will indeed seem them on your flash: under "phones" directory in a new sub directory, and the TFTP statements will be added to IOS, and the system:its/xml file will be created for the new phones...   However, since the SW pack is analysed for phone loads it contains during SW Upgrade on existing (old) IOS, it will attempt to instigate the above and the Telephony-Service CNF files and LOAD statements.   But since the IOS/CME version is not yet upgraded to support the new phones, the later commands wont work.  Net result, phones cant be recognized or loaded.

So after you upgrade and reboot UC520, if you see this behavior, then use PLM to delete the SPA5x5 phone loads and then add them back.  This would then create the telephony-service commands and CNF files and then they should work.....


Joseph Chambers Thu, 10/08/2009 - 11:42

Found another error -

Under Troubleshoot, Telephony Diagnostics, Phone Debug - Gives me error. When I click OK, no phones are shown.

If I try to Voice debug log, get java.lang.NullPointerException. Doesn't appear to turn on any debugs

Saurabh Verma Thu, 10/08/2009 - 11:54
I never received anything on the 2.1.1, and the 2.1 version is useless.

You mean you didn't receive any errors, correct? Or are you saying that the CCA 2.1.1 does not come up at all? I'm sure you meant the error, but just wanted to verify :)



This Discussion

Related Content