CUCM/CUC Integration passing MWI to ISDX phones

Answered Question
Oct 5th, 2009

Hi - Our customer currently has the following installation:

CUCM 7.1.2 (2 node / single site)

CUC 7.1 (single site)

H323 28xx Gateway (single site)

VG30D (single site)

ISDX (single site)

They wish to move their existing ISDX phones to use CUC for voice messaging, however, there

is a requirement for the ISDX phones to have MWI/AMWI to be passed from Unity to the ISDX phones.

The signalling path currently in place is:

CUC SCCP > CUCM H323 > 28XX QSIG > VG30D DPNSS > ISDX

MWI is set in CUCM and turns the lamp off and on ok on Cisco IP Phones, but I am unsure how this would reach the H323 Gateway.

The VG30D documentation refers to the DPNSS Call Back Messaging service

being used to light MWI, however, I am not sure if this is for a DPNSS Messaging

system being used to light the Cisco IP Phones.

any thoughts appreciated

thks

b

I have this problem too.
0 votes
Correct Answer by gogasca about 7 years 3 months ago

Hi b,

MWI should work, calling/connected names, calling/connected

number.

Normally you will see that Unity will be dialing the MWI number and CUCM should catch that is an MWI request and dial the extension in remote cluster normally via your H323 GW, ...

Question here:

1. Any reason to use H.323 and not MGCP?

2. Do you have Annex M1 enabled in H323 and IOS GW ?

Q.SIG standard says 0xA880 and 0xA881 for MWI ON/OFF you can debug that in GW and see if we are sending the message to VG30D, you can always open a TAC case to verify it, Ive seen some internal discussions so its better a detailed analysis in a TAC case, we should be able to tell you which is the culprit here :D

Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
gogasca Tue, 10/06/2009 - 13:01

Hi b,

MWI should work, calling/connected names, calling/connected

number.

Normally you will see that Unity will be dialing the MWI number and CUCM should catch that is an MWI request and dial the extension in remote cluster normally via your H323 GW, ...

Question here:

1. Any reason to use H.323 and not MGCP?

2. Do you have Annex M1 enabled in H323 and IOS GW ?

Q.SIG standard says 0xA880 and 0xA881 for MWI ON/OFF you can debug that in GW and see if we are sending the message to VG30D, you can always open a TAC case to verify it, Ive seen some internal discussions so its better a detailed analysis in a TAC case, we should be able to tell you which is the culprit here :D

Thanks

btmulgrew Tue, 10/06/2009 - 14:04

Thanks a lot. We did manage to get this working with help from TAC and we did switch to mgcp ;)

Though i did think h232 v2 now supported all qsig supp services!

One thing to look out for is how the qsig variant is translated from the PBX, default in CUCM is set to support ISO, though we had to change to ECMA to stop the MWI facility from being rejected.

Actions

This Discussion