Nortel IP 2002 handset and Cisco 2960 - TOS\COS Issues

Unanswered Question
Oct 5th, 2009
User Badges:

We have a problem with Nortel IP Handsets connected to a Cisco 2960 switch. When the handset is connected to the switch it comes up with a "Server Unreachable" message. Traces taken on the network show that the handset sends it's packets tagged with A0 (DSCP CS5). This then passes through the 2960 switch and has the tagging stripped to 00. If we connect the handset to a 2950 or similar the tagging remains A0 and the IPT works okay. If we connect the handset to a 2950 switch and connect that switch to the port on the 2960 that the handset just failed to work on, it then all works okay (so direct into the 2960 you have a problem, but put a 2950 in between and it is fine)


I have erased the config on the 2960, replaced the 2960 and tried several different models (& IOS). All have the same issue.


We tried connecting to 3550 and 3560 switches and had the same problem (A0 stripped to 00). However these were EMI models with qos in the config. This was removed (no qos) and these work okay.


The default on the 2960 is no mls qos so I would have expected this switch to behave the same way.


I have tried configuring the port for all options of auto mls qos; with\without mls qos trust options; with\without no mls qos rewrite ip dscp.


I have not tried configuring up different VLAN's for voice and data (as per the example online) as we have hundreds of sites where the third party contraints is that there is only one VLAN so I have to have a solution that allows a single VLAN1 - basically to allow the 2950 series to be replaced by the 2960 series with minimum impact.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (1 ratings)
Loading.
iyde Mon, 10/05/2009 - 12:06
User Badges:
  • Silver, 250 points or more

Hi Scott.

As far as I am aware the Cat2960 will reset QoS markings to 0 if you do not explicitly enable mls qos and then set trust on the interface (mls qos trust dscp or mls qos trust cos).

But I am a little astonished to hear that a missing QoS marking actually amkes the phone not work at all....

HTH

scott.smith@uk.... Tue, 10/06/2009 - 02:20
User Badges:

Hi,

I have tried the configuration changes suggested and this has not changed anything. Packets are still tagged 00.


For information, the present config is included. Port handset is connected to is fa0/8


service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname XXXXXXXX

!

boot-start-marker

boot-end-marker

!

enable secret 5 $XXXXXXXXXXXXXXXXX

!

no aaa new-model

system mtu routing 1500

ip subnet-zero

!

!

mls qos

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet0/1

spanning-tree portfast

!

interface FastEthernet0/2

spanning-tree portfast

!

interface FastEthernet0/3

spanning-tree portfast

!

interface FastEthernet0/4

spanning-tree portfast

!

interface FastEthernet0/5

spanning-tree portfast

!

interface FastEthernet0/6

spanning-tree portfast

!

interface FastEthernet0/7

spanning-tree portfast

!

interface FastEthernet0/8

mls qos trust cos

!

interface FastEthernet0/9

spanning-tree portfast

!

interface FastEthernet0/10

spanning-tree portfast

!

interface FastEthernet0/11

spanning-tree portfast

!

interface FastEthernet0/12

spanning-tree portfast

!

interface FastEthernet0/13

spanning-tree portfast

!

interface FastEthernet0/14

spanning-tree portfast

!

interface FastEthernet0/15

spanning-tree portfast

!

interface FastEthernet0/16

spanning-tree portfast

!

interface FastEthernet0/17

spanning-tree portfast

!

interface FastEthernet0/18

spanning-tree portfast

!

interface FastEthernet0/19

spanning-tree portfast

!

interface FastEthernet0/20

spanning-tree portfast

!

interface FastEthernet0/21

spanning-tree portfast

!

interface FastEthernet0/22

spanning-tree portfast

!

interface FastEthernet0/23

spanning-tree portfast

!

interface FastEthernet0/24

spanning-tree portfast

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address XX.XX.XX.XX 255.255.248.0

no ip route-cache

!

ip default-gateway XX.XX.XX.XX

ip http server

snmp-server community XXXXXXXXX RW

!

control-plane

!

!

line con 0

password XXXXXX

login

stopbits 1

line vty 0 4

password XXXXXX

login

line vty 5 15

login

!

!

end


scott.smith@uk.... Wed, 10/07/2009 - 06:03
User Badges:

Further investigations and numerous traces taken with the Nortel Handset and the 2960 series of switch's has proven that the tagging issue of A0 to 00 is not the route cause of the connectivity problems on the network. Depending on when the phone converses with the IPT switch, the TOS changes. The standard 2960 config (out of the box) does not affect the TOS - the 3550 and 3560 still does but that is another issue.


The root problem, is that the Nortel handsets, when connected directly to a 2960 do not work, but when connected to a 2950 (which can, in turn, be connected to a 2960) works.


Several power up traces have been taken on the network of a working and failing configuration. The results are repeatable.


The startup sequence of the Nortel IP 2002 Handset (connected to 2950 switch) on the network is as follows:

4 frames DHCP Protocol Packets

44 frames Handset port (GENA) 5000 (TOS 00) and IPT Switch A port 4100 (TOS 00)

86 frames Handset port (GENA) 5000 (TOS A0) and IPT Switch A port 4100 (TOS 00)

44 frames Handset port (GENA) 5000 (TOS A0) and IPT Switch B port 7300 (TOS 00)

18 frames Handset port (GENA) 5000 (TOS A0) and IPT Switch B port 5100 (TOS 00)

28 frames Handset port (GENA) 5000 (TOS 00) and IPT Switch B port 5100 (TOS 00)

98 frames Handset port (GENA) 5000 (TOS A0) and IPT Switch B port 5100 (TOS 00)

2 frames Handset port 5200 (TOS 00) and IPT Switch B port 10000 (TOS 00)

continues Handset port (GENA) 5000 (TOS A0) and IPT Switch B port 5100 (TOS 00)


Port 5200 to port 10000 traffic appears to be when the handset recieves date\time on the display.


The point at which the handset fails to work when connected directly to a 2960 switch is during the conversation been ports 5000 and 7300. On the 16th frame the handset sends a packet, the last. The IPT Switch continues to send packets to the handset but there is no response.


When the handset fails to connect, it goes through a countdown exercise where it tries to reconnect to the server. With an unmanaged hub connected to the 2960 and the handset connected to that, the handset still fails. A trace taken on the hub shows shows that when the handset tries to re-connect, it sends (GENA) port 5000 (TOS 00) to IPT Switch A port 4100 (TOS 00). There is no response and the handset retries twenty more time, every 500ms, then reverts back to Server Unreachable. When the handset sends these packets, traces (using monitor session) were taken on the port the hub was connected to, the port that is the route to the IPT switch and on another Nortel connected directly to the switch - in this setup, no traffic is seen. It is as if the switch is dropping or blocking packets on the incoming port.


In case there is any trunking changing on the 2960 port, show interface gi0/4 trunk when the phone is initially working and again, after it stops working. Both result with the same information.

Port Mode Encapsulation Status Native vlan

Gi0/4 auto 802.1q not-trunking 1


Port Vlans allowed on trunk

Gi0/4 1


Port Vlans allowed and active in management domain

Gi0/4 1


Port Vlans in spanning tree forwarding state and not pruned

Gi0/4 1

scott.smith@uk.... Thu, 10/08/2009 - 06:15
User Badges:


Upgrading the firmware of the handset to version 0604DBN changes the connection profile slightly.

4 frames DHCP Protocol Packets

16 frames Handset port (GENA) 5000 (TOS A0) and IPT Switch A port 4100 (TOS 00)

28 frames Handset port (GENA) 5000 (TOS 00) and IPT Switch A port 4100 (TOS 00)

87 frames Handset port (GENA) 5000 (TOS A0) and IPT Switch A port 4100 (TOS 00)

53 frames Handset port (GENA) 5000 (TOS A0) and IPT Switch B port 7300 (TOS 00)

16 frames Handset port (GENA) 5000 (TOS A0) and IPT Switch B port 5100 (TOS 00)

17 frames Handset port (GENA) 5000 (TOS 00) and IPT Switch B port 5100 (TOS 00)

89 frames Handset port (GENA) 5000 (TOS A0) and IPT Switch B port 5100 (TOS 00)

2 frames Handset port 5200 (TOS 00) and IPT Switch B port 10000 (TOS 00)

50 frames Handset port (GENA) 5000 (TOS A0) and IPT Switch B port 5100 (TOS 00)


It too, fails to connect to the IPT Server.


Traces taken show similar symptoms to previous analysis. However, the handset fails after 26 frames. The time between GENA packets on the handset and the switch dropping the packets is 34ms on the new firmware and 4554ms on the old. The switch is not dropping packets after a set time of voice actitivity.


These further traces once again showed that when the handset was trying to connect, the handset sent the packets (captured on hub) but did not get picked up on the monitor session on the 2960 switch. When the handset fails and packets were captured on the 2960 from the IPT Server, these packets did not reach the handset (on the hub) and they too appear to be dropped, or in another VLAN !!!


The switch interfaces were again checked to see if any trunking had changed - it had not.


On the handsets with firmware 0604DBN, there are more configuration options. Setting Voice 802.1Q to NO allowed the handset to work. Data 802.1Q was set to YES (as NO resulted with handset not tagging data it was sending).


Actions

This Discussion