OSPF Issue - Static Works

Answered Question
Oct 5th, 2009

Hi,



I have BackBone_Switch connecting to MPLS_RTR but using OSPF traffic doesnt flow using static routes it works.



================

BackBone_Switch

=================


vlan15

name Uplink to MPLS_RTR


Interface VLAN15

IP address 192.168.150.1 255.255.255.252


interface fa 4/20

switchport access vlan 15




router ospf 250

network 192.168.150.1 0.0.0.3 area 0



=============

MPLS_RTR

=============


interface fa 0/1

description Connected to BackBone

ip address 192.168.150.2 255.255.255.252


Router ospf 250

network 192.168.150.2 0.0.0.3 area 0



UA_DC#sh ip ospf neighbor


Neighbor ID Pri State Dead Time Address Interface

10.10.10.1 1 FULL/DR 00:00:33 192.168.150.2 Fastethernet0/1


Any help



Correct Answer by Richard Burts about 7 years 4 months ago

Amin


The additional information that you have posted is helpful. From it we can determine tht the MPLS router has one active OSPF interface, which is the interface that connects to the switch. So the only routes that OSPF can learn via OSPF are routes from the switch.


OSPF is redistibuting routes from BGP and this line indicates that this should be working:

Number of external LSA 189.


I would expect some OSPF routes to be learned from the switch. There do not appear to be any. If you would post the output of the commands that I suggested from the switch we might get some insight into what is going on there.


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Peter Paluch Mon, 10/05/2009 - 07:19

Hello Amin,


What routes do you expect to see on the backbone switch? According to your output, the backbone switch is fully adjacent to the MPLS router so generally, there should not be any reachability problem, assuming that you have entered all the proper "network" commands into OSPF configuration so that all necessary networks are being advertised. Also, do you use any VRF tables?


Best regards,

Peter


Amin Shaikh Mon, 10/05/2009 - 08:50

We have couple of networks on BAckbone Switches and couple of networks are learned by MPLS Router.


All advertized on same OSPF ID but are not reachable.


I have not displayed those on the early post.


I have network 192.168.199.0/24 on mpls network.


If I perform sh ip route | incl 192.168.199.0

OUTPUT : no routes to destination, with static entry its fine.


what could be the other reason

Is there any other checks for OSPF


I have also done the following

clear ip route *

clea ip ospf proc *


No luck

Richard Burts Mon, 10/05/2009 - 09:46

Amin


You have not provided enough detail to allow us to figure out what the problem might be.


What you have showed us so far is the configuration of an OSPF process with a single network statement. The result of this single network statement is that the MPLS router and the switch become neighbors. You have not provided any other detail about any other routes? Are there additional networks learned by OSPF on the MPLS router? If so what are they? Are there any other network statements on the MPLS router? If so what are they? Are there any other OSPF neighbors on the MPLS router? If so what are they?


You ask if there are other checks for OSPF. I would suggest that you start with:

- show ip ospf

- show ip ospf interface

- show ip ospf neighbor

- show ip route ospf


If you do these commands it will provide good information about what is going on with OSPF. If you provide the output of these commands from the MPLS router and from the switch then it would give us good information to work from.


HTH


Rick

Amin Shaikh Mon, 10/05/2009 - 11:45

Rick,

Do you suggest any specific debug command to get some clue for the issue.


I have added the config and output

sh ip ospf neigh remains the same as stated in earlier post.


I m planning to upgrade IOS from 12.2 to 12.4 and I have another router 3800 with latest ios for some other purpose, will test with that as well.


================

BackBone_Switch

=================


vlan15

name Uplink to MPLS_RTR


interface Loopback0

ip address 1.1.1.1 255.255.255.255


Interface VLAN15

IP address 192.168.150.1 255.255.255.252


interface VLAN 22

description USER-FARM

IP address 192.168.3.1 255.255.254.0


interface VLAN 23

description SERVER-FARM

IP address 172.16.16.1 255.255.255.0


Interface VLAN 24

description Wireless network

IP address 10.10.250.1 255.255.255.0


Interface VLAN 25

Connected to DU-ISP

IP address 10.10.251.1 255.255.255.252


Interface VLAN 26

description Connected to Juniper-Firewall

IP address 10.10.252.1 255.255.255.252


interface fa 4/20

switchport access vlan 15



router ospf 250

redistribute connected subnets

redistribute static subnets

network 192.168.150.1 0.0.0.3 area 0

network 192.168.3.1 0.0.0.0 area 0

network 172.16.16.1 0.0.0.0 area 0

network 10.10.250.1 0.0.0.0 area 0

network 10.10.251.1 0.0.0.0 area 0

network 1.1.1.1 0.0.0.0 area 0




ip route 0.0.0.0 0.0.0.0 10.10.252.2



=============

MPLS_RTR

=============


interface Loopback0

ip address 172.16.17.1 255.255.255.255


interface fa 0/1

description Connected to BackBone

ip address 192.168.150.2 255.255.255.252


interface fa 0/0

description Connected to SP-NET

ip address 172.39.109.198 255.255.255.252


Router ospf 250

network 192.168.150.2 0.0.0.3 area 0

network 172.16.17.1 0.0.0.0 area 0

redistribute bgp 68909


router bgp 68909

no synchronization

bgp log-neighbor-changes

redistribute connected

redistribute static

redistribute ospf 100

neighbor 172.39.109.197 remote-as 68900

neighbor 172.39.109.197 route-map

no auto-summary






MPLS#sh ip ospf

Routing Process "ospf 250" with ID 172.16.17.1

Supports only single TOS(TOS0) routes

Supports opaque LSA

Supports Link-local Signaling (LLS)

It is an autonomous system boundary router

Redistributing External Routes from,

bgp 68909, includes subnets in redistribution

Initial SPF schedule delay 5000 msecs

Minimum hold time between two consecutive SPFs 10000 msecs

Maximum wait time between two consecutive SPFs 10000 msecs

Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs

LSA group pacing timer 240 secs

Interface flood pacing timer 33 msecs

Retransmission pacing timer 66 msecs

Number of external LSA 189. Checksum Sum 0x5F5365

Number of opaque AS LSA 0. Checksum Sum 0x000000

Number of DCbitless external and opaque AS LSA 0

Number of DoNotAge external and opaque AS LSA 0

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

External flood list length 0

Area BACKBONE(0)

Number of interfaces in this area is 1

Area has no authentication

SPF algorithm last executed 01:06:22.200 ago

SPF algorithm executed 962 times

Area ranges are

Number of LSA 37. Checksum Sum 0x11E07C

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0


MPLS#sh ip ospf interface

FastEthernet0/1 is up, line protocol is up

Internet Address 192.168.150.2/30, Area 0

Process ID 100, Router ID 172.16.17.1, Network Type BROADCAST, Cost: 1

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 172.16.17.1, Interface address 172.20.3.42

Backup Designated router (ID) 1.1.1.1, Interface address 192.168.150.1

MPLS#sh ip route ospf

Correct Answer
Richard Burts Mon, 10/05/2009 - 12:37

Amin


The additional information that you have posted is helpful. From it we can determine tht the MPLS router has one active OSPF interface, which is the interface that connects to the switch. So the only routes that OSPF can learn via OSPF are routes from the switch.


OSPF is redistibuting routes from BGP and this line indicates that this should be working:

Number of external LSA 189.


I would expect some OSPF routes to be learned from the switch. There do not appear to be any. If you would post the output of the commands that I suggested from the switch we might get some insight into what is going on there.


HTH


Rick

Amin Shaikh Mon, 10/05/2009 - 22:28

I upgraded the IOS Version 12.3(11r)T2 and reapplied the OSPF config again and it starts working.


Its weird


Thank you rick and all guyz

Actions

This Discussion