WRVS4400n v 2 firmware bugs

Unanswered Question
Oct 5th, 2009

Was having problems with the WAN dropping repeatedly. Upgraded firmware to newest So far the internet has not dropped. I enabled https for remote management and could no longer get to router. Disabled and can get to router.

I do not have Qos enabled, or any ACL policies. I only enabled IPS for all IM and P2P. Clients were having problems getting to webmail.aol.com. Browser would just hang. Remembered sometime ago that I had an issue with webmail after blocking an IM port. Cisco had me disable half of services, then half again to narrow down service. ICQ instant messenger was the culprit.  Disabled blocking for ICQ and now able to access webmail.

Still however have problem with https remote management.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
David Carr Mon, 10/05/2009 - 10:53

Have you tried alternate ports for management seeing if that allows you to connect?

Eivind Jonassen Mon, 10/05/2009 - 10:59

I´ve ran into a problem when I tried to connect to the router using the Linksys VPN client. The client connects, then the DIAG led is lit and the router hangs... It seems that I´m not able to downgrade the firmware to 1.1.13 where the VPN works. Is cisco aware of this???



joycenord Mon, 10/05/2009 - 11:12

When I do not have https enabled, I can access the router on whatever port I need to.  The minute I enable https, I cannot access it even on the standard port or any other.

David Carr Mon, 10/05/2009 - 11:41

Do you have any port forwarding setup on the router, and is there a possiblity that the secure ports are being blocked.

joycenord Mon, 10/05/2009 - 15:16

I have single port forwarding for 3389, 1212, 3392 and 25 and thats it (all tcp).

I have no internet access policies, no ACL's, no port range forwarding, no triggering, I don't have ProtectLink, nothing configured for QoS, no VLAN's, no VPN's.

The only thing I am blocking under IPS are the IM services and P2P so I don't know how the secure ports would be blocked. I also have Anomoly Detection on for http, ftp, telnet, rpc.

David Carr Tue, 10/06/2009 - 06:19

The reason, I was asking is it seemed that the ports were being blocked or forwarded for https.  That would be the only reason why you could access the port but when https is enabled you are not able to access it.

What type of internet connection do you have?

David Carr Tue, 10/06/2009 - 08:36

Have you tried saving your configuration and doing a factory reset and reloading the configuration.  If this doesn't work, you might have to contact the SBSC at 1866-606-1866 and let them do some troubleshooting with you.  But I would try that first real quick and see if you can access it.

David Carr Tue, 10/06/2009 - 08:45

What operating system are you using to connect to the router using quick vpn?  Are you using a wireless air card? What is the internet connection type at the wrvs4400n?

Eivind Jonassen Tue, 10/06/2009 - 10:18

I´m on Windows XP, the latest Quick VPN software, LAN connection. The customer are connected through a ADSL line...



David Carr Tue, 10/06/2009 - 10:49

Do you have the IPS enabled on the router?  If so, possibly disable that and see if you can connect.  Is the xp machine service pack 3? What are the ip addresses on the router side and the remote side?

David Carr Tue, 10/06/2009 - 11:18

You have the block wan request disabled on the router also.  The wan ip address on the router is it a public ip?

As long as you have a clear path to router and the adsl is not blocking anything it should connect right up.

Is there any way you could send some screen shots of when you try and connect?

Eivind Jonassen Tue, 10/06/2009 - 11:25


The WAN address is a public IP, I can connect to the router, but after about 10-20 seconds the router hangs and the diag led is lit up on the router. This causes the router to hang, the users at the remote side can´t reach the internet and I then have to restart/powercycle the router. I use the same software, exept a linksys firmware on a different router, and I don´t have the issues there. So what I would like is a guide on how to downgrade the firmware on the router, as I think this would solve my problem.



David Carr Tue, 10/06/2009 - 11:37

Here is the link with the firmware downloads


If you have a version 2 wrvs4400n you will download the version of firmware.  If you have a version 1 or 1.1 you would download the

1.1.13 version.

You would download the firmware to your desktop and unzip the file.

Then make sure you have your configuration backed up.

Browse to the file from the administration/firmware upgrade tab.

Select upgrade.   After firmware is upgraded do a factory reset of the router.

Then reload your configuration to the router.

Eivind Jonassen Tue, 10/06/2009 - 11:41


I upgraded from version 1 to 2. And when I try to upload the old firmware (ver 1.x) I get an error saying that the image is not supported. Am I not able to downgrade the router???



Not completely sure if I have the latest QuickVPN client though. I´ll check tomorrow and give you an update..

Message was edited by: Eivind Jonassen

David Carr Tue, 10/06/2009 - 11:50

Yeah, make sure you have the latest client.  There is a rollback utility that can be used to go back in firmware.  It is ther on the firmware download site.

Eivind Jonassen Tue, 11/03/2009 - 07:44


After updating to the latest firmware and software things worked better. I had to do a fatory default on the router though, it continued to "hang" after connecting with VPN.

My issue is solved, hurray :)



joycenord Tue, 10/06/2009 - 09:12

I reset to factory and reconfigured it back and still same problem.

I did contact Cisco for support when I was having problems with the blocking of webmail.aol.com.  That turned out to be a feature in the IPS.  Once I disabled ICQ under the IM, users were fine.

I brought the issue with the remote access via https at that time.  Support didn't even show the option for https in their firmware.  But told me to reset it and try again.  So I did.

Not being able to use https isn't that big of a deal for me.  I'm just wondering how many others out there have this issue and if they have found a workaroudn since support doesn't have an option.

David Carr Tue, 10/06/2009 - 10:47

Joyce, i set this up in the lab and enabled remote management.  I was able to get connected to the router using http.  However when i enabled https and had it accept a connection from any ip address, I was unable to connect to the router.  I changed the port to see if that made a difference and got no luck.  I emailed our escalation team to find out if this is a known issue.  I do know that the firmware is relatively new and we may have located a bug.  I will keep you posted.


This Discussion