Cisco 1841 WAN server related problem

Unanswered Question
Oct 5th, 2009

Hello

I have a WAN with Cisco 1841 routers.

RouterA FE0/0 10.20.10.42/30

FE0/1 192.168.1.100/24

RouterB FE0/0 10.20.10.34/30

FE0/1 192.168.5.100/24

I have a DHCP server hanging off RouterA FE0/1 with ip 192.168.1.153

From RouterA I can ping my DHCP server.

When I connect to RouterB I can ping the FE0/1 interface on routerA but I cannot ping the DHCP server. Yet when I do a traceroute from RouterB the trace hits the FE0/0 interface on router and times out.

I have put in a static mac-address for my DHCP server on RouterA but somehow the mac address does not stay in the address table. After I have added the mac-address and do a sh mac- the table is empty. When I issue the sh arp command I see the 192.168.1.153 hhhh.hhhh.hhhh entry

Does anyone know what I can try to ping my dhcp server from RouterB? If it means I need to add the static mac in like I amtrying to do what do I need to do to make the mac entry stay in the mac table?

I am running IOS flash:c1841-advipservicesk9-mz.124-25a.bin onboth routers.

TIA

wvw

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
u1kumar2002 Mon, 10/05/2009 - 18:47

Dear willem,

After doing the traceroute from Router B if you are hitting Router A Fe0/0. Then your Wan routing is working fine. Plz check whether the Lan segment are advertise properly & check the routing table of both the routers for the entry of the destination networks. If the routing table is having the route the get the destination network, Vice versa in other router. Then you should able to ping the LAN segment of each router.

If then also you are facing problem. Plz check windows default firewall is on or off. Sometimes it could be a reason...

Don't do any static entry of mac address,I think it is not required.

Regards,

Uttam

willemvwyk Thu, 10/08/2009 - 14:23

Hi Uttam

Thanks for your help :) I think you are right. There was no need to configure the routers with static mac addresses in their mac- tables.

Regards

willemvw

kradjesh13 Mon, 10/05/2009 - 21:19

Hi,

I guess the problem might be with the server and the default gateway might not have been properly configured.

When you ping the server from Router A, it will use its connected interface which is Fe0/1 and it will get the reply back. Do an extened ping and use the sourece as fe0/0.

ping 192.168.1.153 source fe 0/0

If you don't get any reply, than definately you can say its the problem with the server and the gateway might not be properly configured.

Please check and let me know and we can proceed further.

Thanks

Rajesh

willemvwyk Thu, 10/08/2009 - 14:27

Hi Rajesh

I think I found the problem. This is related to the dhcp not being "allowed through" What I would like to know is whether the router allows DHCP through automatically or not? If it does not allow it through how do I need to configure the router to allow DHCP traffic through?

Thanks

willemvw

willemvwyk Fri, 10/09/2009 - 15:26

I think I have solved my DHCP Problem. I have added the ip helper-address command but on the LAN interface at the remote site. THe WAN interface receives the dhcp broadcasts, so when I changed that it all worked :)

Thanks for the replies.

Cheers

wvw

Actions

This Discussion