Sip trunk with cisco 2811 dont work!

Unanswered Question
Oct 5th, 2009

Hi, i need help to configure a sip trunk

i have a cisco 3825 with CME and recently bought a sip trunk with a local provider, but i cant get it works.. pls help

the provider said that The sip trunk dont have security, just this parameters to configure.

dir ip X.X.X.X Port 5060

its a openser no user no password.

so this is my sip configuration in the cisco router:

show run...

voice service voip

allow-connections sip to sip

allow-connections h323 to sip

allow-connections sip to h323

allow-connections h323 to h323


voice class codec 1

codec preference 1 g729br8

codec preference 2 g729r8

codec preference 3 g723ar63

codec preference 4 g711ulaw

codec preference 5 g711alaw



dial-peer voice 11 voip

destination-pattern T

voice-class codec 1

session protocol sipv2

session target ipv4:X.X.X.X

dtmf-relay rtp-nte

no vad




But when a called , just hear the busy tone...

and when i recive calls nothings happens

the router dont show any activity with the debug ccsip all, only when i make calls.

so pls, someone, what else have to do to configure ? something missing ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Nicholas Matthews Tue, 10/06/2009 - 06:02

If you're not getting debugs it means the SIP messages aren't processed by the router.

Three primary reasons for this:

1) You have SIP bound to an interface already in voice service voip, and that's not the interface they are sending to.

2) Your IP address on your router does not match what the provider is sending to

3) Provider has an issue routing calls. This could include something like a BGP problem where you're just not advertising it, or something like a call routing mistake on their side.

What does debug ccsip messages look like?


csco11391130 Wed, 10/07/2009 - 13:56


you need to check the codec

i didnt see your codec

i think that you can make call, and the phone ring, but when you hang up, the call end, maybe this is the problem, or you have to check the rtp packets.

csco11391130 Wed, 10/07/2009 - 13:58

can you put the ephone and ephone-dn configure, because you can configure the codec on phone.

I think that is problem of codec, and i didnt see the transcoding


This Discussion