Unanswered Question
Oct 5th, 2009
User Badges:


In ASA and Cisco Router i already open the port for the SFTP which is port 22, but user unable authenticate the SFTP service.

Is it the port i opened incorrect?

pls advise



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Collin Clark Tue, 10/06/2009 - 05:35
User Badges:
  • Purple, 4500 points or more

Are you getting an authentication prompt or a connection timeout?

gilbertcsc Tue, 10/06/2009 - 06:32
User Badges:


Thks i already done the thing, is working fine now.



cisco24x7 Tue, 10/06/2009 - 06:42
User Badges:
  • Silver, 250 points or more

SFTP is a sub-component of SSH. If you are using Linux/Solaris, make sure you have it enable in /etc/ssh/sshd_config file. Like this:

# override default of no subsystems

Subsystem sftp /usr/libexec/openssh/sftp-server

Otherwise, you will not be able to use SFTP.

Try to ssh to the system first. If you can get the authentication prompt, then you know the firewall is opened on port 22. Otherwise, look at your firewall/router configuruation and make sure the port 22 is opened.

Simple right?


This Discussion