7921 phone prefers the G band over A- why?

Unanswered Question
Oct 6th, 2009

We are using 7921 phones over our wireless network with A, B and G APs. The phone is set to Auto-A and the APs are broadcasting the SSID over A and G bands. We are seeing the phones pick the G band 90% of the time. We restricted the SSID to the A radios and the phones worked just fine, but this goes against the philosophy of use A and fail over to G. The phones are using WPA, CCKM (TKIP) and have firmware v.1.3.2 (the 1.3.3 firmware had issues authenticating against RADIUS, but 1.3.2 works). Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
migilles Wed, 10/07/2009 - 12:50

Auto-A gives precedence to 5 GHz, but if unavailable it can switch to 2.4 GHz if available. There is no mechanism to re-scan the preferred band (5 GHz) after failing over to the less preferred band (2.4 GHz) at this time.

We recommend not to have 2.4 GHz signal for the voice ssid in areas where you want to use 5 GHz.

This may require separate WLC or the use of AP groups.


This is also documented in the 7921G Deployment Guide on page 50.


http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/7921g/6_0/english/deployment/guide/7921dply.pdf

Matt Domnick Fri, 10/09/2009 - 08:03

Thanks for the response; I think this is exactly the issue we are seeing.

charlespham Wed, 11/04/2009 - 19:06

Did you ever figure out why the 1.3.3 firmware had issues with authenticating against RADIUS? I am experiencing the same issue, I have a 7921 running 1.0.4 and one running 1.3.3 with identical settings, but the 1.3.3 one has the auth failures.


The only problem is that 1.3.3 can't be downgraded back to anything prior to 1.3.3, so we're stuck with it...

Matt Domnick Thu, 11/05/2009 - 07:40

No, I did not find a reason why; I simply downgraded to the earlier firmware. I did this by going into CM and specifying which firmware to use and this pushed it down to the phone.


Device>Device Settings>Device Defaults and change name to the older firmware.

migilles Thu, 11/05/2009 - 16:18

There was a change in the 1.3(2) release in order to pass WPA/WPA2 enterprise certification, which was to change the auth type from 128 (network-eap) to 0 (open) where EAP is optional.

If you are using the Cisco WLAN Controller, it supports both types by default.

If you are using the Cisco autonomous access points, then need to ensure that you have both methods enabled to cover all firmware versions.


See the 1.3(2) release notes.


http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/7925g/firmware/1_3_2/english/release/notes/792x_132.html#wp223099


There is nothing in 1.3(3) that I can think of that would impact authentication.


As far as roaming back to 5 GHz even though the voice ssid is still present on 2.4 GHz after failing over to 2.4 GHz when configured for Auto-a, we are planning to make some enhancements in this area for the 1.3(4) release, where it will scan both bands when in an auto mode and ensure it is on the preferred band when available.

Actions

This Discussion