SPA9000/3201 AA never disconect when PSTN call in

Unanswered Question
Oct 7th, 2009


I encounter a hard to solve trouble with my LVS system as incoming PSTN calls that go through the AA remain active indefinitely and would be pleased if someone have some clue.

My config is as folow :

  • One SPA9000 (software v6.1.5) with :
    • Line 1 to my ITSP
    • Line 2 to the SPA3201
  • One SPA3201 (software 3.3.6gw) used as VoIP-PSTN gateway
  • Some SPA942 and SPA962 phones

The SPA9000/3201 gateway scheme is done according to the Linksys tutorial "12371 Configuration du SPA3000 comme passerelle PSTN du SPA9000" (also available in english elsewhere on the linksys/cisco website. SPA3201 is not registered with SPA9000 (Voice/PSTN Line/Proxy and registration/Register = No).

My trouble is as folow when I enable AutoAttendant and receive a call from POTS using the FXO port of the SPA3201 :

  • the SPA3201 detect the incoming call on PSTN and rely (Hook state : Off)
  • this call is routed to the SPA9000 AutoAttendant
  • If the caller hung-up without reaching an internal extension (NightTime AA)
    • the SPA3201 doesn't detect disconect (hook state remain Off)
    • hook state remain to Off in SPA3201/Voice/Info/PSTN Line statuts
    • the POTS line become unavailable at the telco operator level (no busy tone, but a message stating that your correspondant is unavailable),
    • the SPA9000 keep the Line2 (SPA3201) inbound call as active for hours (in SPA9000/Voice/Info/PBX statuts)

Differential diagnostic indications :

  • Ther're is no trouble for incoming calls through Line 1 (SIP ITSP)
  • There're is no trouble for incoming calls through PSTN/SPA3201 if AA is not used or if hugh up is done with a SPA phone.
  • The only way to disconnect "struck" PSTN inbound calls is to "Delete" it in web PBX statuts page.

I've tried to change SPA3201 disconnect tone parameters to match my country standards without success.

By the way Caller ID (well detected on SPA3201 web UI) is not used by the SPA9000 that always send me SPA3201 UserID ou DisplayName. PSTNCIDforVoIPCID parameter is on YES.

Is there a way to register SPA3201 with SPA9000 to avoid all those troubles? Or another solution?

Thanks for your help.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
William Childs Thu, 10/08/2009 - 04:19


On the SPA3102 set the "Register" parameter to yes. Give the 3102 an extension for the user id, and set the proxy to the ip address of the WAN ip address. The device should register at that point. Then go to the PSTN tab and set the "PSTN CID for VoIP CID" to yes (you said this was already done). This should allow your 3102 to pass the caller-id info along the voip line to the SPA9000.

You can modify the PSTN Line tab under the PSTN Disconnect Detection section to control how the 3102 handles a call that has been terminated. Set the Detect CPC, Detect Polarity Reversal, Detect PSTN Long Silence, Detect VoIP Long Silence to yes. The Detect CPC will make the SPA3102 understand the CALLING party has hung up and will put the FXS port on hook. The Detect Polarity Reversal is similar to the CPC except it is for a different type of signaling. The Detect PSTN Long Silence will end the call if the line has been silent for the listed number of seconds on the PSTN side. The Detect VoIP Long Silence is the same but from the VoIP side. One thing you should do is make sure the Disconnect Tone is localized for your telephone provider. You could also try lowering the Min CPC Duration parameter to 0.1 from 0.2 (default).

One thing I don't understand is the use of the SPA3102. The SPA400 is designed for specifically this reason/implementation. The only difference is you have an analog phone port on the 3102 that you dont get with the SPA400 (400 is for gateway/voicemail only). It sounds as though you have set it up properly only with a few missteps. Make sure the 3102 gets registered (can be registered on both pstn side and voip side) and that each line has a separate extension.

You did not indicate if you were using the analog line for outgoing calls. I would be interested to see your dialplan on your phones if you are. Depending on the country you are in, a short call to the local Small Business Support Center should have you fixed in no time.

I, however, would recommend that you make use of the SPA400 as it is designed for this particular implementation.

Best of Luck,


chpaulo Sat, 10/10/2009 - 08:33


Thanks for this reply.

This is a quite old installation (setup in 2007 I think). At this time SPA400 wasn't available so I used a SPA3102 as a PTSN-VoIP gateway (inbound-outbound). This installation worked fine (except for PSTN CID) until I had to setup the auto attendant feature.

The analog line is used to place outgoing calls to the PSTN and receive calls from the PSTN. My phone dial plan is very crappy as I never tooked time to optimize it.

I use Call Routing Rules on the SPA9000 (<:L1>9,xxx.|<:L2>8,xxx.) to direct outbound calls to my ITSP (L1, 9 pre dial digit) or PSTN (L2, 8 pre dial digit).

I use a custom dial plan (S0<:[email protected]:5061>) to send all incoming calls on SPA3102 FXS/PSTN Line to the SPA9000 Line 2 as I wasn't able to use the Cisco's configuration provided by document "108762 Setting-up SPA3000 as a PSTN Gateway of SPA9000" wich deserve a revision and more details.

I does not use SPA3102 "VoIP" Line 1, do you mean ("each line has a seperate extension") that i should do so?

My SPA3102 PSTN Line wasn't previously registered with SPA9000 ; this is now done but hadn't fixed any of my troubles (CID, PSTN disconnect).

The SPA9000 Line 2 isn't registering to the SPA3102 but is configured to place calls to SPA3201 PSTN Line without registration.

I've tried without success to use various parameters for SPA3102 "PSTN Disconnect Detection".

This installation is in Senegal wich use the same public network as France, so I tried  french "Disconnect Tone" parameters :

440@-30,440@-30; 2(0.5/0.5/1+2) or 440@-10;*(.5/.5/1). I also tried your parameters (CPC Duration).

Disconect troubles only arise when caller hang-up during AutoAttendant use.

A great mystery!

Alberto Montilla Tue, 10/13/2009 - 02:50

Dear Sir;

I believe the issue has to do with the SPA3102 not properly configured for handling the Specifics (caller ID and disconnect tone) of your country. I suggest you take a look at:

for knowing the configuration of your tones.

For caller ID you would need to use BellCore if you are in USA/CAN or ETSI FSK if you are in Western Europe.



chpaulo Wed, 10/14/2009 - 10:24


Thanks for your help.

Unfortunately I already use the correct parameters for caller ID (ETSI FSK).

CID works fine localy on the SPA3102 as I can see the last caller number on the Voice/Infos tab of the WebUI ; but SPA3102 doesn't transmit CID to the SPA9000 even if I select "PSTN CID For VoIP CID" as when I receive an incoming call from PSTN on a phone the display show the 'User ID" (102) and if setup "Display Name" (SPA3102) from the "subscribe information" part of the "Voice/PSTN Line" tab of the SPA3102.

For the disconnect trouble I already tried the Cisco's recommanded disconnect tone for France and another one recommanded by my telco operator.

Moreover I only run into trouble when using AA.

Any idea?

Thanks for all


chpaulo Sat, 11/14/2009 - 02:51


Finaly after test I obtained a reliable PSTN disconnect on the SPA3102 during AutoAttendant use on SPA9000.

For those interrested I used the folowing parameters that works fine in Senegal :

SPA3201/Voice/PSTN Line/PSTN Disconnect Detection

Detect CPC : Yes

Detect Polarity Reversal : Yes

Detect PSTN Long Silence : Yes

Detect VoIP Long Silence : Yes

PSTN Long Silence Duration : 120

VoIP Long Silence Duration : 120

PSTN Silence Threshold : medium

Min CPC Duration : 0.1

Detect Disconnect Tone : Yes

Disconnect Tone : 440@-30,440@-30; 2(0.5/0.5/1+2)

I still haven't Caller ID passed from SPA3102 through SPA9000 and experience some DTMF tone recognition random trouble with AA but my main problem is solved.



This Discussion

Related Content