UCCX HA Deployment

Answered Question
Oct 7th, 2009

We have are implementing HA in our UCCX enviroment. All CTI ports for both servers are registered. The CTI route points register to the primary and all works fine when it is in production. When we shut down the network access to this the CTI route points do not fail over to the second server in the cluster. Checking the application users the telephony_1 users is associated with the CTI route points but the telephony_2 is not, is this the issue? Looking @ the control panel I see that cluster is in partial service and the culprit appears to be the Unified CM Telephony Subsystem on the second node. Should the CTI route points be associated with both the telephony users, if so can I simply edit this in CCM or should UCCX server be able to do this via a sync?

Thanks,

Joe

Correct Answer by kelvin.blair about 7 years 4 months ago

CTI route points should be associated to both app users. Your best bet is to do a Data/Jtapi Resync which should correct the problem.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
Correct Answer
kelvin.blair Wed, 10/07/2009 - 05:40

CTI route points should be associated to both app users. Your best bet is to do a Data/Jtapi Resync which should correct the problem.

joeharb Wed, 10/07/2009 - 05:49

Can this Data/Jtapi Resync be done during business hours or should it be done after hours?

Thanks,

Joe

kelvin.blair Wed, 10/07/2009 - 05:52

It is always recommended to do things like this afterhours due to a possible impact in business.

atalante Fri, 10/09/2009 - 10:32

Hi,

You have also to check all the SQL services. As you konw UCCX uses SQL replication to synchronise agents informations. Check also the jtapi client version. And there is a replication issue on UCCX 7 after installing OS SR9 (sql hotfix)

Farid

joeharb Sun, 10/11/2009 - 07:23

A Data resync resolved the issue..i was able to do that during a maint window and now the cluster is in full service. I was able to shutdown network connnectivity to the primary and everything failed over to the secondary. Restore went as planned as well.

Thanks for all you help.

Joe

Actions

This Discussion