Syslog FAILCREATEVC Continuously Received by LMS Server

Answered Question
Oct 7th, 2009
User Badges:

hi,


has anyone encountered syslogs being sent to the lms server with a message:


%ATM-3-FAILCREATEVC: ATM failed to create VC(VCD=0, VPI=255, VCI=255) on Interface ATM6/0/3, (Cause of the failure: VC is not an autovc.)


we have noticed that this type of message is being logged frequently by the server in /var/adm/messages


**we're using lms 3.1 on solaris 10


Correct Answer by Joe Clarke about 7 years 9 months ago

Okay, then a config like this should work:


logging discriminator noatm mnemonics drops FAILCREATEVC

logging host x.x.x.x discriminator noatm


Where x.x.x.x is the IP address of your RME server.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
hjavier16 Wed, 10/07/2009 - 08:58
User Badges:

hi jclarke,


thanks for your quick reply. i understand that this is not an issue with LMS, but won't this affect the performance of the LMS server because of the repeated messages being sent to it?

Joe Clarke Wed, 10/07/2009 - 11:34
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yes it could if you're getting more than 200 per second. If you'd rather not see these in your syslog reports, you can create a message filter to exclude them under RME > Tools > Syslog > Message Filters. They will still show up in the local syslog log file, but they will not be added to the RME database.

hjavier16 Wed, 10/07/2009 - 19:47
User Badges:

hi jclarke,


i had added the exceptions on the RME > Tools > Syslog > Message Filters. i'm not sure as to why the /var/adm/messages file still continues to log this message. is it because we have the logging command configured on the device? or is it because there are mistakes in the configuration of the message filter?


please see attached screenshots of the message filter.



Joe Clarke Wed, 10/07/2009 - 20:22
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

As I said, the syslog log will still record the message since you have configured the device to send messages to the RME server. However, the messages will not be added to the RME database, so they will not appear in your syslog reports.


The only ways to keep these messages out of the server's syslog message file is to either stop sending syslog messages to the RME server, fix the problem with the ATM-VC creation issue, or, if the device supports it, use the Embedded Syslog Manager to filter only these messages from being sent by the device. Post a show ver from this device, and I can determine if ESM is a possibility.

Joe Clarke Thu, 10/08/2009 - 08:51
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I think ESM may be supported in this version. Does your router support the "logging filter" command?

hjavier16 Mon, 10/12/2009 - 07:38
User Badges:

logging filter command is not supported in the router

Joe Clarke Mon, 10/12/2009 - 07:40
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Then ESM will not be an option. What about "logging discriminator"?

Correct Answer
Joe Clarke Thu, 10/15/2009 - 08:30
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Okay, then a config like this should work:


logging discriminator noatm mnemonics drops FAILCREATEVC

logging host x.x.x.x discriminator noatm


Where x.x.x.x is the IP address of your RME server.

Actions

This Discussion