7921 wich firmware versions are these?

Unanswered Question
Oct 7th, 2009


I have seen these firmware versions in some of my 7921 iphones (trough web GUI or ip phone menu):

System Load ID CP7921G-MFG-C.2.LOADS

System Load ID CP7921G-MFG-A.7.LOADS

What firmware version are?

Best Regards,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
migilles Wed, 10/07/2009 - 12:40

Yes those are manufacturing loads that are loaded at the factory.

These should only be temporary loads and should upgrdae to the official CCO images. Our latest image is 1.3(3).

The C.2 load equates to the 1.2(1) release and the A.7 load equates to 1.0(5), which are older releases.

Newer firmware can be downloaded @ http://www.cisco.com/cgi-bin/tablebuild.pl/ip-7900ser-crypto.

asafayan Thu, 10/08/2009 - 11:35

Is there any Cisco doc which shows which MFG load maps to which official CCO image?


migilles Thu, 10/08/2009 - 13:49

No there is not, but I just informed you what those 2 mfg loads map to.

asafayan Thu, 10/08/2009 - 14:54


I have CP7921G-MFG-D.3.LOADS. What does that map to?

When these phones are fired up out of the box - they attempt to upgrade firmware and fail with the Firmware Update Failed error message. We run a device default version CP7921G-1.1.1.

Even when we manually configure the Phone Load for this phone to CP7921G-1.3.2 - the lastest we have installed on our Call Managers - the phone attempt to upgrade phone load and fails with the same error message.

This is occuring to all the new phones we have received.

migilles Fri, 10/09/2009 - 18:49

D.3 - D.5 map to the 1.3(3) build cycle.

You will want to update to the 1.3(3) release.

The download from 1.3(3) or compatible mfg loads to earlier versions are permitted.

This is documented in the 1.3(3) release notes.



RKeller31 Thu, 10/15/2009 - 07:26

We are experiencing the same thing now as well - our recent shipments include CP7921G-MFG-D.5.LOADS.

Firmware Update Failed errors either via connection wirelessly to CM or via USB connector.

asafayan Thu, 10/15/2009 - 07:34

The previous message from migilles seems to suggest that the phone should be able to downrev to a load version lower than what it was delivered with. Yet - we could not get that to work. I had to install and install the CP7921G-1.3.3 onto all of our call managers - and then promptly revert our device default back to our older load version. And then manually configure each of the new phones to the CP7921G-1.3.3 load and then they boot with no errors.

Good luck.


RKeller31 Thu, 10/15/2009 - 08:22

Thanks for the response. We did install CP7921G-1.3.3 onto all CMs - and reverted device default back as you suggested. Still getting firmware update failed messages. Working with TAC.

asafayan Thu, 10/15/2009 - 08:29

Reverting the device default was only to prevent all of your phones from downloading the 1.3.3 code. Then you have to manually go into the Call Manager configuration for each new 7921 and add the specific phone load 1.3.3 so that the new phone will download that load. That worked for us and I would be curious to know why it isn't working for you.

migilles Thu, 10/15/2009 - 16:07

If you are running 1.3(3) or an equivalent mfg firmware, then the downgrade to previous images is prohibited.

See my previous posts for this topic.

RKeller31 Mon, 10/19/2009 - 10:55

Okay ... so if 1.3.3 is prohibited from being downgraded to a previous release --- what are our options?

Are they any to utilize a previous firmware with the newly received phones we've received as they appear dedicated to 1.3.3?

migilles Mon, 10/19/2009 - 11:38

You can call TAC to get the interim build if it is really necessary to downgrade from 1.3(3) to a previous release.

But we recommend to use 1.3(3) at this time.

dszendol Thu, 11/12/2009 - 05:03


We have the same problem. 7921 has D.5

CCM has instaled and configured image 1.3.3 but upgrade fails.

migilles Fri, 11/13/2009 - 23:39

After uploading/installing 1.3(3), the TFTP server was restarted correct?

If so, can you tell me what the hardware rev is of the phone?

Navigate to the phone web page and see the Hardware Revision section.


If the hardware revision is 1.x or 2.x, then it should be able to upgrade successfuly.

If the hardware revision is 3.x, then appears related to CSCtc88591.

dszendol Sun, 11/15/2009 - 07:02

I think it was TFTP serwer restart problem. We have loaded the image using another CCM in the lab. Thanks for advice.

migilles Mon, 08/01/2011 - 23:52

D.7 is 1.3(4)SR1.

Recent 7921 hw revs can not run 1.3(3) or earlier. Would need ES or later.

Sent from Cisco Technical Support iPhone App

kristjan.edvardsson Tue, 08/02/2011 - 09:03

I have similar issues. Phone web page says "

CP7921G-MFG-D.7.LOADS" Which equals to 1x version.

The CCM server 8 has 1.3.3. Can the phone not be directly

upgraded to 1.3.3. or do we need to jump to a ealier version first ?

We get an error each time the phone boots up. It registers fine

it is just using the manufactured software it seems.

regards. Kristjan

migilles Tue, 08/02/2011 - 09:57

D.7 equates to 1.3(4)SR1.  If pre-loaded with that mfg image then more than likely you have a 7921 hw rev that can not downgrade to 1.3(3).

We do have a ES that can be loaded onto the 7921s and has the same scanning and roaming logic.

Otherwise would suggest to upgrade to 1.4(1)SR1, which is available on Cisco.com for download, but the scanning and roaming logic was altered a bit as of the 1.3(4) release.

If you want, open a TAC case.

If you want to go forward with the latest generally available phone load, would suggest to try on a phone or two first before doing a bulk upgrade.  Can extract the zip contents and upload 1 by 1, restart TFTP service,  set the necessary phones to the desired phone load, then restart the 792x phone to upgrade the image.

This way will not impact other phone firmware.

kristjan.edvardsson Tue, 08/02/2011 - 10:09

Yes sorry you are right, I mis-read the D in my filename.

I have upgraded the CCM tftp load to 1.4.1SR1

restarted the phone and it upgraded fine.

The CCM had 1.3.3 and the phone it seems 1.3.(4) as you mention.

And they cannot downgrade. But we decided to upgrade

and it worked for one phone. Now we find a suitable time

to upgrade the 69 others..

Thanks !


This Discussion