NSS2000 anonymousftp

Unanswered Question
Oct 7th, 2009

I setup anonymousftp share on my nss2000, I can upload files to it as anonymous, but I cannot delete anything.  I create a username, give it read/write access to this share.  I connect to the CIFS share using this user.  I see the incoming directory, but I do not have any access to the files or directories that were uploaded using the anonymous login.  I get permission denied.

How do I manage the files in this directory?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Alejandro Gallego Wed, 10/07/2009 - 17:18

The anonymous user will not have access to delete files becasue we would not want just anyone to just delete all of the files located in our ftp server. You can manage the share locally via CIFS with the admin account for the NSS. Just log in to the share using the admin credentials and you will be able to manage it with no porblems.

Let us know if that does not work out.

quikah Wed, 10/07/2009 - 17:31

OK, thanks, I tried that, but my domain must be getting in the way.  I tried on another system which wasn't connected to the domain and it worked.

Alejandro Gallego Wed, 10/07/2009 - 18:31

If you try it from a domain computer try mapping the share but use "Connect using a different user name" option and specify the nss admin like this:

"nss_name\admin" where nss_name is the host name of the nss. This would keep you from having to log off or find a non-domain computer.

Good to hear that it worked.


This Discussion