SPA9000 Firmware Upgrade fails

Unanswered Question
Oct 8th, 2009
User Badges:

Hi,


I have read your forum and Google searches - and cannot seem to get my firmware to upgrade to the current version.


Software Version: 3.3.6

Hardware Version 1.2.5(a) (physical hardware has LEDs on Front - so it IS version 2).


I have downloaded the latest Wizard 2-1-0-0 - when doing Firmware upgrade this is what happens:


  1. Go to Firmware Upgrade
  2. Message pops up - Do you have a SPA400 in the network that you plan to use? - NO
  3. Message pops up - Failed to retrieve the device information. Please check your network connection or device type! - OK
  4. Device - Select a device --> SPA9000 <IP> --> Next
  5. Message pops up --- Retreiving latest ...
  6. Firmware Upgrade:
    Load this device firmware (file path is correct)
    Device Type: SPA9000 v2
    Firmware Version: 6.1.5

    Click UPGRADE
  7. Message pops up:
    SPA9000 <IP> is going to be updated.
    File: <path>\spa9000t-6-1-5.bin
    Old version: 3.3.6
    New version: 6.1.5

    Click OK
  8. Message pops up - Sending upgrade request to device <IP>. Please wait ...
  9. Message pops up - Failed to upgrade the device.
    Please check your network connection or device type!

    CLICK OK
  10. (My SPA962 restarts)


I downloaded the firware spa9000t-6-1-5 and this is what happens:


  1. execute upg-spa9000t-6-1-5.exe
  2. Message pops up - WARNING - blah blah - Click CONTINUE
  3. Enter IP address - Click OK
  4. Message pops up - Upgrade fails - no response from SPA


OK so, this is what else I have tried:


  1. Plugging laptop into LAN port of SPA9000 and running wizard - NO CHANGE (errors exactly as above)
  2. unplugging the SPA400 on the LAN (and power) - NO CHANGE (errors exactly as above)


I am using Windows Vista. (yes poor me)


So please, can anyone offer me some help? I really don't want to do a factory reset! It takes ages to put all the configuration settings in! (unless there is a backup configuration utility?)


Cheers,


Ranz

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
simon@npit.co.uk Thu, 10/08/2009 - 05:13
User Badges:

Hi Ranz,


Had the same problem exactly trying to update the SPA942's, and resolved it by downloading a standard tftp server from http://tftpd32.jounin.net/tftpd32_download.html - you'll need to set it up and point the base directory to the location of your spa9000 upgrade bin file.


Then in ie put: http:///admin/upgrade?tftp:///.bin


you should see the upload of the file in the tftp window and flashing lights on the SPA.


Worked for me!


Regards


Simon

serverworldau Thu, 10/08/2009 - 07:20
User Badges:

Hi Simon,


This worked a treat! Thanks for this. I also needed to upgrade the firmware on my SPA962 handsets too - so this saved me even more headaches!


Regards,


Ranz

CrossnetIngenieria Fri, 04/23/2010 - 05:27
User Badges:

I had the same upgrade problem, in two different SPA9000.


I tested the simon solution, through TFTP, and it worked ok with SPA9000 hw version 1.0.5

When I tried the same way in a SPA9000 hw version 1.0.0(580a), the process begun, the status LED started to blink, but after the process, the software version kept being 5.1.9.


Perhaps the 1.0.0(580a) hw version is too old to being upgraded.


Thanks!

Actions

This Discussion