IP SLA Headache

Unanswered Question
Oct 8th, 2009

Hi All

So, I need to measure rtt levels between two devices and trap when it is too high. Sounds like a job for IP SLA right. I am trying to do this on a 7200 and a 6500. When the threshold goes above 30ms I want to send an SNMP trap with custom text, and another SLA for a threshold above 50ms with custom text. I have setup on SLA on the 7200 for a 30 to 40 ms rtt threshold which shows failures but does not send a trap. Here is my config :-

ip sla logging traps

ip sla 1

ip sla reaction-configuration 1 react rtt threshold-value 40 30 action-type trapOnly

ip sla schedule 1 life forever start-time now

snmp-server enable traps ipsla

I can see that the SLA is failing sometimes but does not send a trap as below :-

SLA1#sh ip sla statistics

Round Trip Time (RTT) for Index 1

Latest RTT: 72 milliseconds

Latest operation start time: *12:45:17.355 UTC Thu Oct 8 2009

Latest operation return code: Over threshold

Number of successes: 43

Number of failures: 75

Operation time to live: Forever

Coms to my SNMP trap collector are good as I can shut down an interface and get a trap.

Code version is 12.4(15) Advanced Enterprise.

Is my config broken or is there something more sinister at work here :-s.

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
adamclarkuk_2 Thu, 10/08/2009 - 07:50

I found the answer. As expected, it was broken config.

My re-action config line missed out the reaction type. It should have read :-

ip sla reaction-configuration 1 react rtt threshold-value 60 30 threshold-type immediate action-type trapOnly

yjdabear Thu, 10/08/2009 - 07:52

Try "snmp-server enable traps rtr" instead. I'm not sure what "traps ipsla" does, though it does appear to be valid for some.

Actions

This Discussion