Internal error in communication channel

Answered Question
Oct 8th, 2009

The error is a result of attempting to update the Default Device Credentials in Ciscoworks LMS v3.2. Should I proceed to open a TAC case?

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 7 years 1 month ago

The hostname in NMSROOT/lib/classpath/md.properties, NMSROOT/MDC/etc/regdaemon.xml, and the output of the hostname command must all match (case is not important).

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
jbautistkis Thu, 10/08/2009 - 11:16

Per article, it pertains to a multiserver & certificate set-up, thus,neither are applicable to the set up on our server. FYI....we recently upgrade to v3.2 from v3.01 a few weeks ago.

Joe Clarke Thu, 10/08/2009 - 11:18

The issues with hostname and anti-virus on-access scanning are valid either in a single-server setup.

jbautistkis Thu, 10/08/2009 - 11:43

ok, I'll take a look at anti-virus, however, what about the hostname? Because the hostname on the server has not changed. Unless, the upgrade may have modified the hostname. Would that be possible? Is there somewhere in CSCOpx that I can verify the hostname?

Correct Answer
Joe Clarke Thu, 10/08/2009 - 12:01

The hostname in NMSROOT/lib/classpath/md.properties, NMSROOT/MDC/etc/regdaemon.xml, and the output of the hostname command must all match (case is not important).

Sven Hruza Mon, 10/12/2009 - 01:14

I have the same problem on all my LMS-installations.

One is a multi-server-installation, the others are single-server.

All installations are LMS 3.2

I get this error sometimes and after restart of all processes it works for a random time.

I checked the hostname and they are all right.

Anti-virus is not installed on the servers.

Which logfiles are important for that problem?

Thanks a lot!

I think DEP may be causing this too. (Windows Data Execution Prevention)

You can view the DEP configuration for your computer in System in Control Panel.

To do this, follow these steps:

1. Click Start, click Run, type sysdm.cpl, and then click OK.

2. Click the Advanced tab, and then under Performance, click Settings.

3. In the Performance Options dialog box, click the Data Execution Prevention tab.

Joe Clarke Mon, 10/12/2009 - 08:59

DEP is a known problem, but I haven't seen it cause this. It is recommended one turn on DEP only for critical Windows processes.

Actions

This Discussion