SPA8000 dropping BYE message on instant hotline calls

Unanswered Question
Oct 8th, 2009

We have found what appears to be bug in the SPA8000 (running firmware 6.1.3).

Our dialplan is (S0 <:7000>)
This has the result of an instant hotline.  As soon as the caller picks up the phone the call is immediately connected to our gateway to extension 7000.  Extension 7000 is a conference in our Freeswitch server.  Although the manual suggests to set up a hotline use a dialplan like (P0 <:7000>), we use the S0 because the suggested P0 method results in approximately 1 second of dialtone played to the caller.

We also have the Hook Flash Timer Min and Max timers set to 0 to prevent the user from initiating a 2nd call.

To reproduce the bug the caller performs repeated on-hook/off-hook cycles.  Packet captures and debug logs show that after several of these cycles in short succession, the SPA8000 starts missing some of the BYE messages.  This has the result of having to wait for a timeout to discover that the session is no longer active in the conference.

We have tried adjusting other timers with no change.  We've also tried reenabling the hook-flash, but are still able to reproduce the error, although it is more difficult.  In other systems we've used there are on-hook timers that can be set to prevent this type of caller abuse, whereby a quick hook flash would end them up back in the same call.  If there was a timer such as this we think we wouldn't run into this problem.

Due to our unique requirements and dialplan this is probably an edge case, but nonetheless still appears to bug which we would hope could be addressed in a future firmware update.

If there is another work around to this it would be appreciated.  I can supply additional data or perform tests as needed.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alberto Montilla Tue, 10/13/2009 - 03:15

Dear Sir;


Definitively a corner case ;-). I'll have a look (need to talk to engineering to see alternative options) and let you know.


Regards
Alberto

Alberto Montilla Wed, 10/14/2009 - 02:07

Dear Sir;


Please disable call waiting service in all your lines, that would make the deal (instead of modifying the hook flahs timers).

Regards
Alberto

brendangilmore Wed, 10/14/2009 - 11:21

Dear Alberto,


We have disabled call waiting service and tested.  That resolved the problem!!  This is fantastic, eliminates all dialtone and gives us an instant connection at off-hook.  We very much appreciate your time and response.  We look forward to using additional SPA devices in the future. 


Thanks,

Brendan

Actions

This Discussion

Related Content