Wlan Clients cannot see each other

Unanswered Question
Oct 8th, 2009

I have an 877w Dot11Radio interface with a pretty standard setup, the issue I'm having is the Wlan clients can't see/ping each other. They can all surf the net though. Do I need to allow mu to mu comms somehow?

interface Dot11Radio0

ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip nat enable

ip virtual-reassembly


encryption mode ciphers tkip


ssid 10


speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0

station-role root

no cdp enable


dot11 ssid 10

authentication open

authentication key-management wpa

wpa-psk ascii 7 xxxxxxxxxxxxx


import all


domain-name xxxxxxxx



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
rob.huffman Fri, 10/09/2009 - 05:43

Hi Mathew,

On standard Autonomous AP's this is controlled via PSPF I'm not sure about the 877w but I thought it was worth a try;

Enabling and Disabling Public Secure Packet Forwarding

Public Secure Packet Forwarding (PSPF) prevents client devices associated to an access point from inadvertently sharing files or communicating with other client devices associated to the access point. It provides Internet access to client devices without providing other capabilities of a LAN. This feature is useful for public wireless networks like those installed in airports or on college campuses.


Note To prevent communication between clients associated to different access points, you must set up protected ports on the switch to which your access points are connected. See the "Configuring Protected Ports" section for instructions on setting up protected ports.


To enable and disable PSPF using CLI commands on your access point, you use bridge groups. You can find a detailed explanation of bridge groups and instructions for implementing them in this document:

•Cisco IOS Bridging and IBM Networking Configuration Guide, Release 12.2. Click this link to browse to the Configuring Transparent Bridging chapter: http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fibm_c/bcfpart1/bcftb.htm

You can also enable and disable PSPF using the web-browser interface. The PSPF setting is on the Radio Settings pages.

PSPF is disabled by default. Beginning in privileged EXEC mode, follow these steps to enable PSPF:

Command Purpose

Step 1

configure terminal

Enter global configuration mode.

Step 2

interface dot11radio { 0 | 1 }

Enter interface configuration mode for the radio interface. The 2.4-GHz radio is radio 0, and the 5-GHz radio is radio 1.

Step 3

bridge-group group port-protected

Enable PSPF.

Step 4


Return to privileged EXEC mode.

Step 5

copy running-config startup-config

(Optional) Save your entries in the configuration file.

Use the no form of the command to disable PSPF.


Hope this helps!


MATHEW ATTWATER Sun, 10/11/2009 - 01:49

Thank you very much for your reply. It would seem all it took was to blow away my Dot11radio 0 interface and replce a very basic config (layer 3 on the dot 0 int).

All working fine.


This Discussion