IP static routing

Unanswered Question
Oct 9th, 2009
User Badges:

hostname RTA

!

interface Loopback0

no ip address

!

interface Loopback1

no ip address

!

interface FastEthernet0/0

ip address 141.202.1.1 255.255.192.0

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

no ip address

shutdown

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

ip classless

ip route 141.202.0.0 255.255.192.0 Serial2/0

!

line con 0

line vty 0 4

login

!

end


hostname RTB

!

interface Loopback0

no ip address

!

interface Loopback1

no ip address

!

interface FastEthernet0/0

ip address 141.202.33.1 255.255.192.0

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

no ip address

shutdown

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

ip classless

ip route 141.202.0.0 255.255.192.0 Serial2/0

!

no cdp run

!

line con 0

line vty 0 4

login

!

end


hostname RTC

!

interface Loopback0

no ip address

!

interface FastEthernet0/0

ip address 141.202.17.1 255.255.192.0

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

no ip address

shutdown

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

ip classless

ip route 141.202.0.0 255.255.192.0 Serial2/0

!

no cdp run

!

line con 0

line vty 0 4

login

!

end


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Fri, 10/09/2009 - 04:07
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Max


You post some configs, but no question. What is the question you wish us to help you with?


Assuming that the question is about the validity of the configs I see at least 2 serious problems. The static routes point to interfaces that are shut down. If a static route points to an interface that is not up/up then the static route will not be put into the routing table.


Also your static routes point to serial interfaces. But the serial interfaces are configured with no ip address. If an interface is not configured with an IP address then it will NOT pass IP traffic.


Other than this, is there a question you want to ask?


HTH


Rick

stokesm3475 Sat, 10/10/2009 - 15:22
User Badges:

i'd thought that was suppose to do the trick, so instead of Fa0/0 i should go to Serial Interface 2/0. is that all i should do or is their something else.

Lucien Avramov Sat, 10/10/2009 - 16:04
User Badges:
  • Red, 2250 points or more

Issue a show ip route and look at the routing table.


Actions

This Discussion