Cisco VPN client and multicast

Answered Question
Oct 9th, 2009

I have an XP PC which is at a remote site, which I need to connect to my company's network via VPN client. This PC has 2 NIC cards - one for a private LAN, which receives data via multicast, and a public LAN, which will be used for VPN.

When I connect the VPN, the multicast receiving stops. Is there any way to enable it on the second (private) NIC card?

I have this problem too.
0 votes
Correct Answer by auraza about 7 years 3 months ago

Can you go into the Network Properties of the card, and disable / uncheck the Deterministic Network Enhancer, and see if that makes a difference?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
auraza Fri, 10/09/2009 - 05:46

Do you receive any other traffic on that interface? Unicast? Or is it just multicast that stops?

markwysong Fri, 10/09/2009 - 06:06

I receive other traffic on that interface. Seems everything works on that NIC except multicast, like that address space has been "disabled".

auraza Fri, 10/09/2009 - 06:24

Can you enable logging on the VPN client to Level 15. What you would do is first enable logging and change all the log levels to 3, then close the GUI. Open the vpnclient.ini file under c:\program files\cisco systems\vpn client\ and change all the LogLevel=3 to LogLevel=15. Save the file, then launch the GUI, and launch the Log Window - don't change any Log settings.

Once you connect, see if you catch anything in the logs when receiving multicast traffic about it being dropped etc. You could also run wireshark on that interface to see if the physical interface actually sees the packet.

markwysong Fri, 10/09/2009 - 07:04

No, I don't. I see a bunch of stuff with the VPN connecting, but nothing about multicast traffic.

markwysong Fri, 10/09/2009 - 07:34

I've installed wireshark, but evidently it can't see my network cards. Maybe I need to reboot...

markwysong Fri, 10/09/2009 - 07:47

Wireshark shows the multicast traffic on the second NIC card until the VPN connects. Then it disappears altogether.

Correct Answer
auraza Fri, 10/09/2009 - 08:03

Can you go into the Network Properties of the card, and disable / uncheck the Deterministic Network Enhancer, and see if that makes a difference?

markwysong Fri, 10/09/2009 - 09:00

WOW...that seemed to work....you're a genius. Thank you very much!

auraza Fri, 10/09/2009 - 09:28

Oh, good. Would appreciate if you could rate the post!

Thanks!

markwysong Fri, 10/09/2009 - 09:47

Done!! I can't thank you enough. This just saved a lot of travel, and thousands of dollars of troubleshooting.

Actions

This Discussion