LMS3.0.1/CS3.1.1: backup fail: "Cannot stat: No such file or directory"

Unanswered Question
Oct 9th, 2009
User Badges:

Hi,

Backup failed this morning.

I found the error message in this thread:

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=Network%20Management&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.2cd25df9/5#selected_message

We can see on the server HKEY_LOCAL_MACHINE/Software/Cygnus Solutions/Cygwin.

We have find both cygwin dll in CSCOpx folder and Network Registrar Network.

Openssh for windows is not install.

Cygwin is not install.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Fri, 10/09/2009 - 07:29
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Uninstall CNR, then reset the registry keys as documented in the workaround for the bug. LMS must be the only provider of cygwin1.dll. As was stated in the above post, LMS 3.1 and higher no longer uses Cygwin for backup.

ebezombes Fri, 10/09/2009 - 08:20
User Badges:

At the customer place, CNR was always install on the same server with LMS.

Before LMS backup use to work, why now it doesn't ?

Joe Clarke Fri, 10/09/2009 - 08:58
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Without seeing the full log, it's impossible to say. But if the Cygwin DLL and registry keys exist, and there was a change such that they didn't exist before, then that would be a reason the backup would be failing now.

Joe Clarke Fri, 10/09/2009 - 11:03
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There is a problem stating C:/PROGRA~1/CSCOpx/objects/smarts/local/repos/icf/DFM.rps-14268. Does this file exist? Perhaps it was deleted while the backup was running.

Actions

This Discussion