AnyConnect client no assigned address error

Unanswered Question
Oct 9th, 2009

I am trying to set up the AnyConnect client (v2.4.0196) and when it tries to connect it fails with a no assigned address error. I look in the logs of the ASA and see a No IPv6 address available for SVC connection. IPv6 is disabled on the ASA.

Does anyone know how to prevent the AnyConnect client from trying to get an IPv6 address?

Thanks in advance...

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Herbert Baerten Mon, 10/12/2009 - 23:14

Note that 2.4 is still beta, 2.3.2016 is the latest supported release today.

Having said that, I rather suspect an ASA issue than a client issue. Can you confirm whether or not an ipv4 address is assigned?

I.e. is there something in the logs like:

Oct 13 2009 09:05:55: %ASA-6-737026: IPAA: Client assigned from local pool

Oct 13 2009 09:05:55: %ASA-6-737006: IPAA: Local pool request succeeded for tunnel-group 'DefaultWEBVPNGroup'

(note these are level 6 messages)

I downgraded my client to 2.3.0254 and still got the same result. What fixed it for me was adding the address pool to the tunnel-group DefaultWEBVPNGroup. When using the VPN wizard, the wizard asks you to create a tunnel group and assigns the address pool to this new group, but not to the DefaultWEBVPNGroup. I guess it must be a bug because the wizard makes no mention of this group, but in order to make it work, you have to use this group.


This Discussion