Non Cisco IP Phone with cisco Switch

Unanswered Question
Oct 10th, 2009

Hi All,

I have Alcatel IP Phones, these ip phones are connected to cisco switch (3560) inturn PC's are conneted to this IP Phone the configuration i did in the cisco switch was

inter gi0/1

switchport access vlan 10

switchport voice vlan 20

exit

after this these ip phones are not registering with itz call manager, i noticed the DHCP log it is getting IP address from the data vlan not from the voice vlan. I knew that it should be configured that trunk, but can any assit on this.

regards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jerry Ye Sun, 10/11/2009 - 14:09

I am not 100% sure how Alcatel IP phones negotiate the 802.1q settings via DHCP. However, the following setting will work for Avaya phone, I suspected this should work for Alcatel also.

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 10,20

switchport mode trunk

spanning-tree portfast trunk

HTH,

jerry

What type of Alcatel phone is it, does it support trunking? I would just put hte switch port in the vlan for voice and see if it registers. IF it does, you know the battle is on the phone side and how it deals with the 2 vlans. I don't believe Alcatel recognize the "voice vlan" command on the switch like the Cisco phones do. If you get me the model phone I may be able to give more info.

jagan_240 Sun, 10/11/2009 - 21:29

Hi Jerry,

thanks a lot for your information, I tried yesterday with the same, but still IP Phones are not registering.

fremgen,

the model of IP Phone is Alcatel IP Touch 4028. I am not getting proper support from this Alcatel Engineer to check will it support trunking or not. Is there any other way to get rid off this Issue?

regards,

jagan_240 Sun, 10/11/2009 - 21:32

This Ip Phone is not going through voice vlan only. It is trying to get ip from NAC Auth vlan. the DHCP options are correct in my config

jagan_240 Mon, 10/12/2009 - 23:21

Hi Jerry,

I tried but still, itz the same. Is there any other work arround? i need to have different vlans voice and data. But yesterday i did some settings in the Alcatel IP Phione as mentioned below

PC--->IP Phone---->C3560

the interface leading from the IP Phone to switch, in that i changed vlan to voice vlan but after that my Data vlan started to give issue. Any suggestions are highly appreciable

regards

Jerry Ye Mon, 10/12/2009 - 23:38

Do you mean you have the switchport voice vlan command? Or you change the native vlan to the voice vlan id?

I am trying to understand what you changed.

Regards,

jerry

jagan_240 Mon, 10/12/2009 - 23:42

Hi Jerry,

I have changed the VLAN from default 1 to voice vlan 10 in the IP Phone, after that IP Phones started to work, but since PC is also connected to the same IP Phone in the different vlan , it has started to give issue.

regards

Jerry Ye Tue, 10/13/2009 - 00:11

Oh, okay. Looks like the phone is not doing 802.1q trunking with the switch. Can you paste the interface configuration here?

Regards,

jerry

jagan_240 Tue, 10/13/2009 - 00:18

Hi Jerry,

Find the below config from switch port

switchport trunk native vlan 800

switchport trunk allowed vlan 1-23,25- 4094

switchport mode trunk

spanning-tree portfast

Jerry Ye Tue, 10/13/2009 - 00:21

Are you using 802.1q trunk? Can you post the command show int x/x switchport.

Regards,

jerry

jagan_240 Tue, 10/13/2009 - 00:47

Hi Jerry,

Yeah Im using 802.1q and find the output below

Switch#sh interfaces fastEthernet 0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 24 (IT)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk associations: none

Administrative private-vlan trunk mappings: none

Operational private-vlan: none

Trunking VLANs Enabled: 1-799,801-4094

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

Jerry Ye Tue, 10/13/2009 - 00:54

Hm... I can't see what is wrong. Maybe it is late at night.

jagan_240 Tue, 10/13/2009 - 01:00

typical issue ah? :-). I think this IP Phone may not support trunking. Can any one put their suggesstions on this?

Actions

This Discussion