Issue with IP Communicator 7.0.3

Unanswered Question
Oct 11th, 2009

Hi All

I have a problem with the new version of IP communicator 7-0-3

I have it installed but it comes with an error “unable to initialize support for Cisco emergency responder “

It doesn't seem to cause any issues for the CIPC to function but, this message comes every time you restart the CIPC.

Is there away to resolve this issue? Any help will be much appreciated.

Thanks

Mohammed

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.
virverma Sun, 10/11/2009 - 22:42

Hi,

This is an existing issue.

The only workaround you need to prevent the error message on startup is to disable CDP. Disabling CDP means disabling the Cisco Emergency Responder feature (911 support). It will not affect anything else. If the customer setup does not have CER server disabling CDP is safe.

To disable CDP:

Open registry editor - Run regedit

Get to the key HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\Communicator\ Add EnableCDP as a DWORD value.

Set its value to 0 (To enable it later change the value to 1. By default, the key doesn't exist and the default value is 1).

Zeek Ferraros Tue, 03/23/2010 - 08:29

Hi, I am having the same error message when starting IPC.

I am running 7.0.3.3 on Windows 7 Pro 64bits.

I tried to add the EnableCDP to the registry but there is no directory for Cisco System under HKEY Local Machine

I was able to add the EnableCDP on the followin path HKEY_CURRENT_USER\SOFTWARE\Cisco Systems, Inc.\Communicator\ (but not sure if it's the same bcause I am still getting the error message)

Let me know if you have any other suggestion.

Thanks,

Zeek

I had the same problem, running version 7.0.3.0 on Windows 7 64bit and  receiving the error. Found that the key didn't exist as Ezequiel  mentioned. I did a quick search and found that the Communicator key is  under HKLM\Software\Wow6432Node\Cisco Systems, Inc.\Communicator\ added  the EnableCDP key (Dword) and it worked.

Hope this helps someone in the future.

Cornelio M Thu, 05/31/2012 - 14:14

Just an update to this post for Windows 7 x64

1. Run regedit

2. Go to "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Cisco Systems, Inc.\Communicator"

3. Create: DWORD for EnableCDP then place in 0

*It does not work on QWORD, as I tried it.

Actions

This Discussion