Question on EIGRP design

Unanswered Question
Oct 11th, 2009

Hi,

I am planning to run the EIGRP in my netowrk. Here is my requirements.

1) A,B,C,D,E locations connected to SP VPLs (full mesh)

2) A,B,C,D will have full routes of each location.

3) If any body wantS to communicate to any location, he shOULD contact directly to that location. he should not touch the other locations

4) Suppose if i want to communicate to A -> B location.It should contact directly to B as EIGRP path selction is based on BW+DELAY s, it may contact via C to B like this A-C-B

Som more Ex:

B->A ---- B-D-A ----> if B wants to communicate to A. it shld directly contact to A. it shld not go trgh B-D-A

C->D --- C-B-D ----> if c wants to communicate to D. it shld directly contact to D. it shld not go trgh c-b-d

Regards

Sateesh

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
CriscoSystems Sun, 10/11/2009 - 21:33

What is your concern? If you've got a full mesh topology and each circuit has equal bandwidth, EIGRP won't route traffic through a third hop.

I can't think of any protocol that WOULD, either...

Giuseppe Larosa Sun, 10/11/2009 - 23:00

Hello Sateesh,

as Stuey has pointed out you have the equivalent of a LAN segment with your VPLS full-mesh.

This means each site receives directly the EIGRP updates of each other site and doesn't use a site x to reach sitey's IP subnets.

even if you manipulate delay and BW your settings will apply to all EIGRP updates received on VPLS facing interface.

Also EIGRP uses split-horizon concept: site B will never advertise on VPLS segment siteC's IP subnets, because it has learned these routes on this same interface.

unless you have an alternate path with another technology and/or provider.

Hope to help

Giuseppe

sateeshk10 Mon, 10/12/2009 - 05:35

Hi,

I appreciate your qucik and clear replies.

Here some more concerns

1) BW is not equal at all the locations

2) All links are terminating on Ethernet, So atleast we can say that DELAY will be equal ryt?

I have 2options here:

1) We need manipulate BW on interface and make it equal at all the locations. Is it ryt/any issue will araise after manipulating the BW?

2) As BW is diffrent @ all the locations, so Can I say that consider only DELAY as metric by modifying the K value like this

metric 0 0 0 1 0 with this config, can we confirm that its goiong to consider only DELAY?

Looking for some more suggestions/let me know which option I need to opt.

Regards

Sateesh

Giuseppe Larosa Mon, 10/12/2009 - 06:55

Hello Sateesh,

bandwidth and delay parameters that EIGRP takes in account are administrative parameters that don't reflect the real speed and delay of link.

You should be fine with default settings regardless of the interface type on each device.

However, if speeds are different you may need QoS tools like outbound shaping in order to avoid to put too much traffic toward a link with less avaliable BW at access.

It is more a question of QoS application then a routing issue.

Hope to help

Giuseppe

sateeshk10 Wed, 10/14/2009 - 22:14

Hi,

Thanks for your reply.

Here some more concerns about config

Here is some of the config from locations. Is this right way of design/approach as my suspection is @ BO can we advertise spceific route /16 rather than /8? please let me know the best practice

@ HO: On interface we have configured summary address and also same subnet Advertised in EIGRP also is this required?

Can we tweak the config to avoid the future routing loop or Is it ok?

===================================

router eigrp 100 --- A (Head office)

passive-interface default

no passive-interface GigabitEthernet3/1

network 10.55.0.0 0.0.255.255

network 10.0.0.0

no auto-summary

interface GigabitEthernet3/1

description VPLS connection

no switchport

ip address 10.255.10.50 255.255.255.0

ip summary-address eigrp 100 10.55.0.0 255.255.0.0 5

speed 1000

duplex full

end

Actual subnet 10.55.0.0/16

========================================

router eigrp 100 ----- B(Branch office)

network 10.0.0.0

Actual subnet --- 10.53.0.0/16

====================================

router eigrp 100 ----- C(Branch office)

network 10.0.0.0

no auto-summary

no eigrp log-neighbor-changes

10.75.0.0 --- Actual subnet.

Regards

Kumar

Giuseppe Larosa Wed, 10/14/2009 - 23:45

Hello Kumar,

if your address plan allows for route summarization sending out only a /16 from each remote site is fine.

Be aware that when you see

router eigrp 100

network 10.0.0.0

this doesn't mean net 10/8 will be advertised.

This means every interface with an IP subnet that is in block 10/8 will have EIGRP running on it and it will be advertised with its own mask within major network 10.0.0.0.

passive-interface avoids that EIGRP sends out EIGRP hellos and also it cannot receive updates on it (because updates can be received only by neighbors and no neighbors are possible if local device cannot send hellos)

Now, given this each remote site will receive all subnets or summary routes within network 10.0.0.0 each with its own next-hop.

So HQ will see

10.53.0.0/16 via branch B

10.75.0.0/16 via branch C

and so on

By the way,

I hope that networks 10.53.0.0/16 are summary routes and not IP subnets associated to a LAN interface.

To leave room to grow in the future use /24 subnets on sites.

on VPLS facing interface use

ip summary-address eigrp 100 10.53.0.0 255.255.0.0 201

Hope to help

Giuseppe

sateeshk10 Thu, 10/15/2009 - 04:03

Hello,

I am bit confused with ur ans.

I am planning to paste the below config at all locations is it ok? or required any modification.

@Location A : I configured summary address on interface as well advertised in EIGRP. I hope one is enough right?

All branches subnet comes under 10.0.0.0 only.

Ex:

10.55.0.0/16-A

10.70.0.0/16 - B

10.53.0.0/16 -c

10.10.0.0 -D

10.20.0.0/16 etc

At each location you want me to advertise specfic network /16 or /8 in EIGRP?which one is best practice?

===================================

router eigrp 100 --- A (Head office)

passive-interface default

no passive-interface GigabitEthernet3/1

network 10.55.0.0 0.0.255.255

no auto-summary

interface GigabitEthernet3/1

description VPLS connection

no switchport

ip address 10.255.10.50 255.255.255.0

ip summary-address eigrp 100 10.55.0.0 255.255.0.0 5

speed 1000

duplex full

end

Actual subnet 10.55.0.0/16

========================================

router eigrp 100 ----- B(Branch office)

network 10.53.0.0 0.0.255.255

no auto-summary

passive-interface default

no passive-interface GigabitEthernet3/1

Actual subnet --- 10.53.0.0/16

====================================

router eigrp 100 ----- C(Branch office)

network 10.75.0.0 0.0.255.255

no auto-summary

passive-interface default

no passive-interface GigabitEthernet3/1

10.75.0.0 --- Actual subnet.

===============================

Regards

Kumar

Giuseppe Larosa Thu, 10/15/2009 - 05:18

Hello Kumar,

you probably have subnets /16 so you don't need to create summary routes.

I wouldn't summarize to 10/8 at headquarter too because this is like a LAN.

be aware that with your VPLS full mesh if two remote sites need to exchange traffic they don't use the HQ.

this is not an Hub and spoke.

You should be fine with this config.

I just tried to point out that having /16 subnets is not a good idea and that you should use further subnetting at remote sites

Hope to help

Giuseppe

sateeshk10 Thu, 10/15/2009 - 06:05

Hello,

I appreciate for useful info.

1)you probably have subnets /16 so you don't need to create summary routes.

R u talking about interface config

router eigrp 100 --- A (Head office)

passive-interface default

no passive-interface GigabitEthernet3/1

network 10.55.0.0 0.0.255.255 --------------------- Need to remove this as already adv in EIGRP ryt..This what you are saying

no auto-summary

interface GigabitEthernet3/1

description VPLS connection

no switchport

ip address 10.255.10.50 255.255.255.0

ip summary-address eigrp 100 10.55.0.0 255.255.0.0 5

speed 1000

duplex full

end

2) I just tried to point out that having /16 subnets is not a good idea and that you should use further subnetting at remote sites

you mean to say that better to go for /24?

3) Its full mesh not Hub & spoke

Regards

Kumar

Giuseppe Larosa Thu, 10/15/2009 - 09:04

Hello Kumar,

1)

I was saying the opposite

each branch router eigrp config should be:

router eigrp 100

passive-interface default

no passive-interface GigabitEthernet3/1

network 10.55.0.0 0.0.255.255

! you still need a nework command

! for VPLS subnet

network 10.255.10.0 0.0.0.255

no summary-address is needed if your client Vlan interface is already

10.55.x.y /16

2)

I would deploy /24 subnets on client vlans

you need to leave space for possible new subnets (for example in the future you may want to have a vlan for servers, one for printers, one for users, one for guests and so on).

it is good to assign a /16 to each site but it is a good idea to avoid to waste also private ip addresses.

if you do so then an ip eigrp summary-address can be used to minimize routes exchanged on VPLS

Hope to help

Giuseppe

sateeshk10 Thu, 10/15/2009 - 17:41

Hi,

1) no summary-address is needed if your client Vlan interface is already

10.55.x.y /16 ?

2) if possible please give me the final config(EIGRP) at Head office and Branch side, how it should as i am going to deplay the same next week onwards.

I have given all details in my mails..

Regards

Kumar

Giuseppe Larosa Fri, 10/16/2009 - 01:05

Hello Kumar,

1)

what is the network mask used in client vlans on each site?

How many IP subnets are you using in each site?

a) 1 and it is a /16

b) multiple ip subnets within a /16 block

if b) you need the summary-address

if a) you don't need it.

2)

minimal configuration

router eigrp 100

network 10.0.0.0

no auto-summary

passive-interface default

no passive-interface gix/y

!

int gix/y

! to be used if b) is true

ip summary-address eigrp 100 10.Y.0.0 255.255.0.0 201

! Y depends from each site

gix/y stands for gi3/1 or else depending on site.

Hope to help

Giuseppe

Actions

This Discussion