Dynamic User Tracking Incorrect OID

Answered Question

macuhic.log is filled with Incorrect OID errors



class com.cisco.nm.cm.ut.uhic.mac.AsnDecoder.AsnObject: CB-Error-incorrectoid: Skt IP Address: 139.78.103.99, Incorrect OID: 1.3.6.1.6.3.1.1.5.3, location ctxt: AsnMakeMe_snmp_v2c, SNMPv2c

Decoder Stage: deviceIP : 139.78.103.99 timeStamp : 30083207 Processed : false

class com.cisco.nm.cm.ut.uhic.mac.AsnDecoder.AsnObject: CB-Error-incorrectoid: Skt IP Address: 139.78.103.99, Incorrect OID: 1.3.6.1.4.1.9.9.500.0.0.1, location ctxt: AsnMakeMe_snmp_v2c, SNMPv2c

Decoder Stage: deviceIP : 139.78.103.99 timeStamp : 30086951 Processed : false

class com.cisco.nm.cm.ut.uhic.mac.AsnDecoder.AsnObject: CB-Error-incorrectoid: Skt IP Address: 10.193.225.1, Incorrect OID: 1.3.6.1.6.3.1.1.5.5, location ctxt: AsnMakeMe_snmp_v2c, SNMPv2c

Decoder Stage: deviceIP : 10.193.225.1 timeStamp : 31619009 Processed : false


Correct Answer by Joe Clarke about 7 years 4 months ago

Yeah, when I looked at the log again, I realized this wasn't the bug I thought it was, and told your engineer to verify the device config.

Correct Answer by Joe Clarke about 7 years 4 months ago

This is a bug. I have been waiting for a customer to test my patch, and report back before I filed the bug. If you open a TAC service request, I can provide you with this patch to test.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Joe Clarke Mon, 10/12/2009 - 06:42

This is a bug. I have been waiting for a customer to test my patch, and report back before I filed the bug. If you open a TAC service request, I can provide you with this patch to test.

Correct Answer
Joe Clarke Mon, 10/12/2009 - 08:58

Yeah, when I looked at the log again, I realized this wasn't the bug I thought it was, and told your engineer to verify the device config.

ppoiron Wed, 08/04/2010 - 01:01

Hello Joe,


Do you know what was wrong in device config because I have the same symptoms on 3550 switches ?


class com.cisco.nm.cm.ut.uhic.mac.AsnDecoder.AsnObject: CB-Error-incorrectoid: Skt IP Address: 10.128.145.17, Incorrect OID: 1.3.6.1.4.1.9.1.485, location ctxt: AsnMakeMe_snmp_v1, SNMPv1
Decoder Stage: deviceIP : null  timeStamp : 0  Processed : false
class com.cisco.nm.cm.ut.uhic.mac.AsnDecoder.AsnObject: CB-Error-incorrectoid: Skt IP Address: 10.128.145.17, Incorrect OID: 1.3.6.1.4.1.9.1.485, location ctxt: AsnMakeMe_snmp_v1, SNMPv1
Decoder Stage: deviceIP : null  timeStamp : 0  Processed : false

Thanks in advance,


Patrice

Joe Clarke Wed, 08/04/2010 - 09:57

The problem was that the device was sending all traps to udp/1431 on the LMS server.  Campus only cares about CISCO-MAC-NOTIFICATION-MIB traps.  The device should only be configured as:


snmp-server host x.x.x.x COMMUNITY udp-port 1431  mac-notification

ppoiron Thu, 08/05/2010 - 01:05

I put this configuration on 3500 switch:


conf t

mac address-table notification change

mac address-table notification change interval 15

snmp-server host aa.bb.cc.dd XXXXXX udp-port 1431 mac-notification

int range fa0/1 - 24

snmp trap mac-notification change added

snmp trap mac-notification change removed

end

Normally, only mac-notification traps would be sent to LMS.

I will take a look on received traps on LMS.

Actions

This Discussion