No ringback when calling over Vitelity SIP trunk

Answered Question
Oct 12th, 2009

Hello,

I have a SIP DID from Vitelity connected to my 2821 H323 gateway and CUCM 7.1.

When I make a call over SIP I don't hear any ringback, but the call is routed correctly and the call works fine once the called-party answers.

Here is some of my gateway config;

-------------------------------------------

voice service voip

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol cisco

h323

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

!

!

voice class h323 1

h225 timeout tcp establish 3

interface Loopback0

description ******H323 GATEWAY ADDRESS******

ip address 10.10.10.1 255.255.255.255

h323-gateway voip interface

h323-gateway voip h323-id C2821

h323-gateway voip bind srcaddr 10.10.10.1

dial-peer voice 1 voip

destination-pattern ..........

voice-class codec 1

session target ipv4:192.168.1.10

incoming called-number .

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 2 voip

destination-pattern .T

progress_ind setup enable 3

progress_ind alert enable 8

voice-class codec 1

session protocol sipv2

session target sip-server

session transport udp

incoming called-number 9T

dtmf-relay rtp-nte

!

!

gateway

timer receive-rtp 1200

!

sip-ua

credentials username [removed] password 7 [removed] realm asterisk

authentication username [removed] password 7 [removed] realm asterisk

no remote-party-id

retry invite 2

retry register 2

registrar ipv4:140.239.143.5 expires 3600

sip-server ipv4:140.239.143.5

host-registrar

-------------------------------------------

Any ideas are appreciated, thanks in advance!

I have this problem too.
0 votes
Correct Answer by sshams007 about 7 years 1 month ago

Hi , i got the issue resolved at one of our customer site.. we had to configure an IOS MTP and also restarted the IP Voice media streaming service

Correct Answer by Nicholas Matthews about 7 years 1 month ago

You should make sure that the codec you have chosen is being negotiated ( and available on the MTP). If you're trying to use G.729 you'll need a software MTP on a router.

Also make sure that the MRGL has access to the MTP. The INVITE that is sent to the PBX should have information under it, an SDP. It should include IP addresses, codecs, etc.

-nick

Correct Answer by Nicholas Matthews about 7 years 1 month ago

This isn't very easy to explain -

Your H323 side is not doing fast start and you're getting media in your 1xx message to the Asterisks.

You need to do media negotiation in order to hear ringback in this case. The gateway cannot send its media to the Asterisks in this case because it cannot send any type of response at this point in the call flow. If the Asterisks supported rel1xx messaging, you would be able to.

The only workaround is to check 'MTP Required' on the H323 gateway in CUCM and check 'Enable Outbound Faststart'.

If you're determined not to use MTPs, you will need to switch your trunk to CUCM to SIP. In 12.4(20)T and later you can use the CUBE feature 'DO-EO', which is the 'early-offer forced' command.

-nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Nicholas Matthews Tue, 10/13/2009 - 06:00

Try removing these commands from your dial peer:

progress_ind setup enable 3

progress_ind alert enable 8

and then post 'debug ccsip message'

-nick

dmotloch Tue, 10/13/2009 - 17:42

I think this may be a bug/defect in 7.1 OR

CUCM 7.1 is not compatible with the router ISO you have running for your SIP trunk.

We've upgraded from 6.12 to 7.12 and this problem started with us...but only calling from 7.1 to CUBE/SIP trunk to the far end CUCM with UCCX. No ring back is the symptom for also.

Haven't had time to fix it yet.

sshams007 Thu, 10/15/2009 - 10:23

Hi,

Can you assign the right Locale and also the annunciators in your MRGL which is assigend tothe trunk. This should solve the problem.

Thanks,

Sandeep

Brian Carlson Thu, 10/15/2009 - 16:16

Hello,

Attached to this post is the result of "debug ccsip message".

I still do not receive ringback even after removing the "progress_ind" commands from my dial-peer.

Calling Party: 4152341021

Called Party: 9139917299

Correct Answer
Nicholas Matthews Thu, 10/15/2009 - 17:58

This isn't very easy to explain -

Your H323 side is not doing fast start and you're getting media in your 1xx message to the Asterisks.

You need to do media negotiation in order to hear ringback in this case. The gateway cannot send its media to the Asterisks in this case because it cannot send any type of response at this point in the call flow. If the Asterisks supported rel1xx messaging, you would be able to.

The only workaround is to check 'MTP Required' on the H323 gateway in CUCM and check 'Enable Outbound Faststart'.

If you're determined not to use MTPs, you will need to switch your trunk to CUCM to SIP. In 12.4(20)T and later you can use the CUBE feature 'DO-EO', which is the 'early-offer forced' command.

-nick

Brian Carlson Thu, 10/15/2009 - 18:34

I checked "Enable Outbound Faststart" and "MTP Required", but I still don't hear ringback. I am using the default software MTP in CUCM 7.1. Do I need to configure one on my 2821 gateway?

Correct Answer
Nicholas Matthews Thu, 10/15/2009 - 18:46

You should make sure that the codec you have chosen is being negotiated ( and available on the MTP). If you're trying to use G.729 you'll need a software MTP on a router.

Also make sure that the MRGL has access to the MTP. The INVITE that is sent to the PBX should have information under it, an SDP. It should include IP addresses, codecs, etc.

-nick

sshams007 Thu, 10/15/2009 - 20:13

Hi,

Just curious to know if you assigned the roght locale to the SIP trunk on callmanager and also ensure yo have the MRGL assigned to the SIP trunk and that MRGL should have the Annunciators

Correct Answer
sshams007 Mon, 10/19/2009 - 09:06

Hi , i got the issue resolved at one of our customer site.. we had to configure an IOS MTP and also restarted the IP Voice media streaming service

Brian Carlson Mon, 10/19/2009 - 09:08

sshams007-

Thanks for the advice. I will try that and let you know how it works out.

Brian Carlson Tue, 10/20/2009 - 11:27

The issue is now resolved! I'm now getting ringback for both inbound and outbound calls.

Here's what I did.

---Configured a hardware MTP on my Voice Gateway using a PVDM2-32

sccp ccm group 1

bind interface Loopback0

associate ccm 1 priority 1

associate profile 1 register GW_MTP

!

dspfarm profile 1 mtp

description Media Termination Point

codec g711ulaw

maximum sessions hardware 8

associate application SCCP

---Configured the MTP within CUCM as an "Cisco IOS Enhanced Software Media Termination Point"

---Made the following changes to my H323 gateway

checked "Media Termination Point Required"

checked "Enable Inbound FastStart"

checked "Enable Outbound FastStart"

After making those changes, ring back works. Thanks everyone!!

Actions

This Discussion