SPA2102 Tag RTP

Unanswered Question
Oct 12th, 2009
User Badges:

Hello,

I actually use an SPA2102 with 2 SIP accounts. The first one, on the line 1 use QOS by tagging RTP packets :


Network Settings
SIP ToS/DiffServ Value:SIP CoS Value:[0-7]
RTP ToS/DiffServ Value:RTP CoS Value:[0-7]
Network Jitter Level:lowmediumhighvery highextremely highJitter Buffer Adjustment:up and downup onlydown onlydisable


and with tcpdump i see the TOS tag on RTP packets :

15:50:21.779694 IP (tos 0xb8, ttl 249, id 36671, offset 0, flags [none], length: 200)


I use exactly the same parameters for the second line :

Network Settings
SIP ToS/DiffServ Value:SIP CoS Value:[0-7]
RTP ToS/DiffServ Value:RTP CoS Value:[0-7]
Network Jitter Level:lowmediumhighvery highextremely highJitter Buffer Adjustment:up and downup onlydown onlydisable


but the tag isn't put ... so no QOS

15:50:21.780789 IP (tos 0x0, ttl 121, id 21154, offset 0, flags [none]


Is there any bug in firmware ? (i am in 5-2-10.bin)


Thanks !

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
William Childs Mon, 10/12/2009 - 22:34
User Badges:
  • Bronze, 100 points or more

From what I see you are using the default settings of the SPA2102. One thing you did not say was if you have the QOS enabled on the WAN interface. If you select Router, then WAN Setup you will find at the bottom of the page "QOS Settings". Under this topic, you will find QOS QDisc: with an option box containing TBF and CBQ. Token Bucket Filter information can be found here:


http://lartc.org/howto/lartc.qdisc.classless.html


and CBQ information can be found here:


http://www.icir.org/floyd/cbq.html


According to your needs you should set this information accordingly.


I also am curious as to how you are capturing these packets. I understand you are using tcpdump, but did you set the debug level to 3 on the device and have the debug server as your ip address or are you doing port mirroring on a switch port?


Bill

guillaume.mevel29 Mon, 10/12/2009 - 23:22
User Badges:

Thanks a lot for answering,


My wan parameters :

QOS Settings
QOS QDisc:NONETBFMaximum Uplink Speed:(Kbps)


In fact I only want to tag RTP packets, on line 1 and 2. I don't want to limit upload speed.


I don't understand why it work on the first line, and not on the second ...


Yes, i use mirroring on internet port to the the tag with TCPDUMP.


Does the SIP and RTP TOS must be enabled somewhere to be active ?


In fact i have about 1000 SPA2102 on a Wimax network, with always the line1 configured. They all use provisionning, and I don't understand why, with about 100 SPA, the TOS TAG on RTP packet isn't put. The SPA use firmware version 3.3.6


Thanks

William Childs Mon, 10/12/2009 - 23:45
User Badges:
  • Bronze, 100 points or more

In the initial post you said you were using Firmware 5.2.10. I am unclear about which devices (you said you had 1000 that were on wimax but only 100 not performing properly?) are not working. Please help me understand how many devices are having the issue, what the firmware version is of each device, and the hardware version of each. Please set the QOS settings on the wan port (this is where all of your RTP stream goes to leave the SPA) for CBQ and then set the speed as high as you like ( 100 mbps would be fine/100000 kbps) so as not to "limit" the interface. We also use Wireshark for packet capture. Set the debug level to 3 and the debug server to your pc's ip address, instead of using port mirroring.


Bill

guillaume.mevel29 Tue, 10/13/2009 - 00:21
User Badges:

ok,

The 1000 SPA use :

Software Version:3.3.6Hardware Version:1.3.5(a)


and some of them never put the RTP tag.


I am going to try to put the qos policy on my spa to see if it work but i only have the TBF option (no CBQ)

I don't understand : Set the debug level to 3 and the debug server to your pc's ip address, instead of using port mirroring


Where can i set the debug level to 3 and the debug server to my pc's ip ? on the ATA ?


My last question ...

I use autoprovisionning with the SPA, but i don't know how to "re-force" automaticaly a provisionning, without making *** 73738#1


because when i want to change a parameter on the 1000 SPA, i can't do this ...


Is it possible to force the download of the new firmware without typing http://192.168.2.10/upgrade?tftp://192.168.2.150/spa2102-5-2-5.bin ... by autoprovisionning ?


Thanks

guillaume.mevel29 Tue, 10/13/2009 - 00:33
User Badges:

I put the TBF policy, but nothing has changed :


09:24:04.336114 IP (tos 0x0, ttl 250, id 25766, offset 0, flags [none], proto UDP (17), length 200) x188.149.115.16444 > 212.155.135.209.9142: UDP


and another one, on the same network , same configuration :


09:32:56.523800 IP (tos 0xb8, ttl 250, id 45278, offset 0, flags [none], proto UDP (17), length 200) x.188.149.97.16458 > 212.155.135.209.9338: UDP


If you want i can give you in private the IP address of an SPA .


Guillaume

William Childs Tue, 10/13/2009 - 01:48
User Badges:
  • Bronze, 100 points or more

Select the System tab and at the bottom there is a field for the debug server. Set that to the ip address of your pc, and then set the debug level to 3. Start your wireshark program and capture the packets. Then post this packet capture in your next post. While you are at it, upgrade the firmware on the affected devices and see if that fixes your issue.


For the auto provisioning, you could try just resetting the SPA2102. There is a field called "Resync Periodic: 3600" set this to 30 seconds in your provisioning file. This will make the device resync every 30 seconds. Once your testing is done, you can set it back to 3600 (1 hour).


The SPA2102 only marks the traffic. It does not make decisions (like a switch) on which packets to forward, unless this device is the gateway for the network. By default, (without TBF and CBQ being enabled) the device should mark ALL RTP packets with the TOS and COS you have defined. According to the screenshot, your devices are running the 3.3.6 firmware. Please upgrade the affected devices to the latest firmware and see if the issues still exists.


Bill

guillaume.mevel29 Tue, 10/13/2009 - 08:05
User Badges:

ok, I just finished my test.


The config :


QOS QDisc:NONETBFMaximum Uplink Speed:(Kbps)


Network Settings
SIP ToS/DiffServ Value:SIP CoS Value:[0-7]
RTP ToS/DiffServ Value:RTP CoS Value:[0-7]
Network Jitter Level:lowmediumhighvery highextremely highJitter Buffer Adjustment:up and downup onlydown onlydisable


I tested with the old and the new firmware, and there is no tag ...


I know the SPA only tag packets, and that is exactly what i want, because the Wimax Base station put the RTP packets in Real time.


I give you by mail the dump of the debug server


Thanks

Alberto Montilla Tue, 10/20/2009 - 10:31
User Badges:
  • Cisco Employee,

Dear Sir;


Thanks for your details. I'm escalating this to engineering, looks like a bug, so that they can replicate.


Regards
Alberto

guillaume.mevel29 Thu, 10/22/2009 - 00:11
User Badges:

Thank you for answering, and I hope you will found an answer to understand this QOS tag.

Alberto Montilla Mon, 10/26/2009 - 04:44
User Badges:
  • Cisco Employee,

Dear Sir;


Engineering could not replicate the issue (they see tags on both SIP and RTP for both lines). Could you please make sure you are using the latest firmware and take traces that shows the issue? We would like to see whether this is something specific or general to a specific configuration. In addition, if you can provide your configuration (send all over a private message), that would help.


Regards
Alberto

Actions

This Discussion