multicast output drops

Unanswered Question
Oct 12th, 2009
User Badges:

I have a SVI running PIM. With 1 sender and 1 receiver on a single muticast group over a the same VLAN, I get no data loss. As soon as I add another receiver (igmp join), I experience data loss and output drops on the all of the receivers ports.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 10/13/2009 - 10:14
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Philip,

may you add some more details like:

platform

IOS image


config of your SVI


sh ip igmp groups

sh ip igmp snooping vlan SVI#


sh ip igmp snooping groups


sh ip igmp snooping querier


this can help to understand what is happening.


Hope to help

Giuseppe


plavine Tue, 10/13/2009 - 10:50
User Badges:


Oct 13 14:45:46.260 EDT: %SYS-5-CONFIG_I: Configured from console by chief on vty0 (10.202.128.7)h ver

Cisco IOS Software, Catalyst 4000 L3 Switch Software (cat4000-I9S-M), Version 12.2(25)EWA4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Fri 23-Sep-05 13:31 by ssearch

Image text-base: 0x10000000, data-base: 0x114DFF08


ROM: 12.2(20r)EW1

Dagobah Revision 226, Swamp Revision 34


njds04 uptime is 2 years, 48 weeks, 3 days, 22 hours, 31 minutes

System returned to ROM by power-on

System restarted at 15:59:47 est Wed Nov 8 2006

System image file is "bootflash:"


cisco WS-C4506 (MPC8245) processor (revision 10) with 262144K bytes of memory.

Processor board ID FOX072301Q9

MPC8245 CPU at 266Mhz, Supervisor II+

Last reset from PowerUp

5 Virtual Ethernet interfaces

242 Gigabit Ethernet interfaces

511K bytes of non-volatile configuration memory.


Configuration register is 0x2101


+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

!


!

interface GigabitEthernet2/1

description *** TRUNK to njds03_g2/1 ***

switchport trunk encapsulation isl

switchport trunk allowed vlan 200-203

switchport mode trunk

logging event link-status

speed 1000

duplex full




!

interface Vlan200

ip address 10.210.200.254 255.255.255.0

ip helper-address 10.210.206.255

ip helper-address 10.210.206.8

ip helper-address 10.210.206.47

ip helper-address 10.210.206.2

ip directed-broadcast

ip pim sparse-dense-mode

standby 200 ip 10.210.200.252

standby 200 priority 110

standby 200 preempt

standby 200 name PROD_FLEX



++++++++++++++++++++++++++++++++++++++++++++++++++++++


njds04#sh ip igmp groups

IGMP Connected Group Membership

Group Address Interface Uptime Expires Last Reporter

239.255.255.250 Vlan200 15:00:02 00:02:40 10.210.200.174

224.9.10.11 Vlan200 05:41:13 00:02:43 10.210.200.133

224.10.10.21 Vlan200 14:46:35 00:02:38 10.210.200.186

239.255.219.45 Vlan200 14:46:29 00:02:47 10.210.200.154

239.10.9.1 Vlan200 15:00:01 00:02:39 10.210.200.184

239.9.10.11 Vlan200 15:00:01 00:02:38 10.210.200.130

239.10.10.3 Vlan200 10:32:46 00:02:41 10.210.200.154

239.10.10.4 Vlan200 10:22:09 00:02:38 10.210.200.130

224.0.1.40 Vlan200 15:00:02 00:02:43 10.210.200.253



njds04#sh ip igmp snooping vlan 200

Global IGMP Snooping configuration:

-----------------------------------

IGMP snooping : Enabled

IGMPv3 snooping : Enabled

Report suppression : Enabled

TCN solicit query : Disabled

TCN flood query count : 2


Vlan 200:

--------

IGMP snooping : Enabled

IGMPv2 immediate leave : Disabled

Explicit host tracking : Enabled

Multicast router learning mode : pim-dvmrp

CGMP interoperability mode : IGMP_ONLY




njds04#sh ip igmp snooping groups

Vlan Group Version Port List

---------------------------------------------------------

200 224.0.1.40 v2 Gi2/1

200 239.9.10.11 v2 Gi5/2, Gi5/6

200 224.9.10.11 v2 Gi5/5

200 239.10.9.1 v2 Gi2/24, Gi2/26, Gi5/2, Gi5/5, Gi5/6

200 239.10.10.3 v2 Gi2/1, Gi5/5

200 239.10.10.4 v2 Gi5/2, Gi5/6

200 224.10.10.21 v2 Gi2/1, Gi2/24, Gi2/26, Gi5/2, Gi5/5, Gi5/6

200 239.255.219.45 v2 Gi2/1

200 239.255.255.250v2 Gi2/1


njds04#sh ip igmp snooping querier

Vlan IP Address IGMP Version Port

---------------------------------------------------

200 10.210.200.253 v2 Gi2/1



Giuseppe Larosa Wed, 10/14/2009 - 11:46
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Philip,

sorry for the late answer


I don't see anything wrong in the shows you have provided.


I tried to do a bug search for your switch and IOS image


the search of bugs related to multicast provides 170 entries.


Hope to help

Giuseppe


plavine Wed, 10/14/2009 - 12:01
User Badges:

If the switch is running the following modules:


WS-X4548-GB-RJ45


and if there are 2 receiver hosts on the same ASIC(I am assuming ports 1-8) would there be an issue if the sender was sending multicast at nearly gigbit speed (on a different blade), would the switch drop data since it would be bound by the 1 gigabit shared between the 8 ports on the receiver's ASIC

Giuseppe Larosa Wed, 10/14/2009 - 12:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Philip,

you have hit the ball!


this limitation exists in this linecard and we have seen it with unicast traffic.


I cannot find the document now, but I've seen the same with unicast traffic in our network during new servers testings.


1 Gbps multicast traffic ? are you using a traffic generator?


Hope to help

Giuseppe


plavine Wed, 10/14/2009 - 12:23
User Badges:

Yes I am using atraffic generator - mtools it is able to generate linespeed traffic @ the sender

Actions

This Discussion