CSM load balancing.

Unanswered Question
Oct 13th, 2009
User Badges:

Hi ,


I have CSM module on the cat 6500 switch and the issue is the content switch module is not balancing the request to the servers.

IT only sends to one server were as it should do the load balance and send it to all the servers packets by packets.


Kindly let me know what needs to be changed on CSM (Virtual server) to do the load balancing properly.


No issues with config as confirm by another engineer.Probes been configured properly it was workingg fine before but not now.


Please have a look.

<Snippet>

Short config from device:-


vserver neha60

virtual 80.102.100.89 tcp www

serverfarm neha60

persistent rebalance

advertise

probe http

inservice


serverfarm neha60

nat server

no nat client

predictor leastconns

real 20.20.100.2:6008

inservice

real 20.20.100.2:6018

inservice

real 20.20.100.2:6088

inservice

real 20.20.100.2:6038

inservice

real 20.20.100.2:6048

inservice

real 20.20.100.6:6008

inservice

real 10.130.150.10 8012

inservice

real 20.20.100.6:6018

inservice

real 20.20.100.6:6038

inservice

real 20.20.100.10:6088

inservice

real 20.20.100.10:6018

inservice

real 20.20.100.6:6038

inservice

real 20.20.100.10:6048

inservice


and there are more.....


Cisco6502#sh module csm 1 reals




20.20.100.2:6008 neha60 6 OPERATIONAL 0 ----No hits-------

20.20.100.2:6018 neha60 6 OPERATIONAL 0 ----No hits-------

20.20.100.2:6088 neha60 6 OPERATIONAL 29

20.20.100.2:6038 neha60 6 OPERATIONAL 0 ----No hits-------

20.20.100.2:6048 neha60 6 OPERATIONAL 0 ----No hits-------


20.20.100.6:6008 neha60 6 OPERATIONAL 6

20.20.100.6:6020 neha60 6 OPERATIONAL 0

20.20.100.6:6018 neha60 6 OPERATIONAL 0 ----No hits-------

20.20.100.6:6038 neha60 6 OPERATIONAL 0 ----No hits-------

20.20.100.6:6048 neha60 6 OPERATIONAL 0 ----No hits-------

20.20.100.20:6008 neha60 6 OPERATIONAL 0 ----No hits-------


20.20.100.10:6018 neha60 6 OPERATIONAL 0 ----No hits-------

20.20.100.10:6088 neha60 6 OPERATIONAL 20

20.20.100.10:6038 neha60 6 OPERATIONAL 0

20.20.100.10:6048 neha60 6 OPERATIONAL 0


</<Snippet>

regards,

Neha.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nehakulsum Tue, 10/20/2009 - 08:04
User Badges:

Hi Inayath,

Thanks. But why is that only couple of servers with parameters are been hit? If bug is the cause then all the servers with any port number should not have been hit?


Thanks in advance.


Regards,

Neha.

vladimirsaltao Thu, 10/29/2009 - 03:43
User Badges:

Did you try to remove some of the reals ( leave only 3 or 4 ) to see if this still happens?

Actions

This Discussion