Call Manager 7.1.2 backup fails

Unanswered Question
Oct 13th, 2009

I have freeftpd installed on a server that backs up call manager every day. I am running SFTP as a service on that server, but when we log off the server SFTP stops and CCM cannot be backed up.

Does anyone know of any SFTP software that cisco recommends to be used as SFTP and that does not stop even after administrator logs off the server.

Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
James Hawkins Tue, 10/13/2009 - 05:45

Cisco do not certify any software but they would point you to Titan FTP Server as a commercial product.

http://www.titanftp.com/products/titanftp/index.html?gclid=CKqXh9aSup0CFYwA4wodhk1Uig

The main problem with Titan is cost = $1000 for the Enterprise version that supports SFTP.

An alternative freeware product is OpenSSH for Windows

http://sshwindows.sourceforge.net/

This works well but as it is a Linux port there is no friendly GUI - you have to use CLI commands.

I have also used Serv-U which is cheaper than Titan but still costs quite a bit.

http://www.serv-u.com/

I wish Cisco would either develop their own Windows SFTP server for UC backups or throw some $$$ the way of the guy who wrote freeftpd so he can sort out the issues with it running as a service.

If anyone can suggest other products I would be interested.

James Hawkins Tue, 11/16/2010 - 08:29

Hi Jonathan,

We have used Sysax for a few clients and recently had a report that the backup fails when the file size transferred is just under 1GB. I have reproduced this by using Filezilla client to upload to a test Sysax server and it does seem to be a problem.

Have you encountered this and, if so, have you found a fix?

Thanks

David Hailey Tue, 11/16/2010 - 09:28

Best software used is CopSSH.  We at Chesapeake NetCraftsmen recommend it to EVERY customer that does not

have an existing solution (and even then we'll recommend it).  It's free, we've never had it fail, and it's reliable.

We even have a blog on how to set it up on www.netcraftsmen.net.

Hailey

Please rate helpful posts!

njachiet Tue, 11/16/2010 - 09:34

FreeFTPd and CoreFTP are both very easy to install and configure. You can run it has system service if needed (FreeFTPd ask it at the end of the installation).

James Hawkins Tue, 11/16/2010 - 10:18

Thanks for the replies guys.

Freeftpd actually has the same restriction as Sysax - it is documented in bug ID CSCsm21349

I have tried copssh (using Bill's blog ) and it works graet but is a little bit "unfriendly" for users used to Windows applications.

I have fired off a message to Sysax support and will post here if I get any useful feedback.

Has anyone tried CoreFTP with 1Gb+ uploads?

Actions

This Discussion